[SOLVED] OH3 ZWave Binding is unable to find Technisat Dimmer

Tags: #<Tag:0x00007f4341d7f538> #<Tag:0x00007f4341d7f470>

Hi,

i have some trouble adding my Technisat Dimmer in the GIRA version as a Thing throug the ZWave Binding.

Technisat Dimmer

Environment:

  • Raspberry Pi 3
  • Z Wave UZB Dongle, Z-Wave.me
  • openhab 3.0.1
  • Already running some Fibaro devices and two Technisat single switches

The Technisat dimmer is reckognized as 0299:0004:1A92:2.0
According to the binding documentation this means, the device is not in the database.
I enabled debug logging and checked the log. The ZWaveThingHandler checkes every device but is unable to find thing type (0299:0004:1A92:2.0). Searching for Technisat finds three devices to check (zwave:technisat_shutter_00_000, zwave:technisat_03009498_00_000, zwave:technisat_seriesswitch_00_000) but the dimmer seams missing. But it is listed in the database on opensmarthome.org and is approved.

Database-Screenshot-Technisat-Dimmer

I performed an upgrade, but it dosen’t help.

I can provide the node xml if necessary. But as an new user it is not allowed :wink:

Are there any ideas how to solve this problem.

Thanks for your help.

EDIT: I earned a new trust level and added the node xml.

network_ed68341f__node_12.xml (10.1 KB)

Manually update to the latest snapshot binding. There was a database export issue for 3.x that was resolved recently. That is why the database entry shows 2.5.12 instead of 3.0.1.

Many people use the install script.
Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

Thanks for the quick reply. I will try this and give a feedback.

1 Like

Unfortunately, that didn’t help. The script takes longer than two minutes to uninstall the ZWave binding.

I have read through the comments and it looks like the script is not yet adapted to OH3. I’ll try my luck again tomorrow with the path to OH3 in the script.

The README file for the script has the manual instructions.

Basically you delete the zwave binding and put a downloaded jar of the snapshot in the addons folder. The UI will not show it as in stalled but it can be used.

1 Like

I already downloaded the last Snapshot and read how to manually install it.
I’ll try it and provide the informations in case someone else runs in this problem.

1 Like

Works :slight_smile:

Steps to solve with manual installation of Z Wave binding:

  1. Openhab Backup: The path and filename can be freely chosen, the extension must be .zip

sudo openhab-cli backup /home/pi/openhab/Backup/2021-02-09-backup-3.0.1.zip

  1. Uninstall ZWave Binding: Go into the Openhab UI as usual, e.g. localhost:8080 in the browser.

Settings -> Bindings -> ZWave Binding -> uninstall

  1. Download latest ZWave Binding snapshot openHAB-ZWave [Jenkins] -> org.openhab.binding.zwave-3.1.0-SNAPSHOT.jar

  2. Copy it to the addon directory of Openhab. Take the correct directory for this from the documentation openHAB on Linux | openHAB

sudo cp /home/pi/Downloads/org.openhab.binding.zwave-3.1.0-SNAPSHOT.jar /usr/share/openhab/addons

  1. Restart openhab: In my case openhab is a service:

sudo systemctl restart openhab.service

Important: The binding is not listed under bindings now. But as @Bruce_Osborne mentioned it still works.

  1. Remove not correctly detected device (Technisat Dimmer):

Settings -> Things -> Technisat Dimmer -> delete Thing

  1. Add new device:

Settings -> Things -> + -> ZWave Binding -> Scan

  1. Create items for the device and link them to channels

  2. Use

Troubleshooting:

  • ZWave controller and devices uninitialized or Error:Bridge: wait a bit until openhab has finished starting and the binding recognizes the controller. If that doesn’t help restart Raspberry Pi or the used system.

Thanks @Bruce_Osborne for the support.

1 Like

You are welcome.

Remember to remove the manually installed binding before upgrading. Of course you would need to install the zwave binding again afterward.

I’ll remember that, thanks.
Now i wait for the offical release.

1 Like

Hopefully in the next 3.x.x release or Milestone. There were some GitHub repo name changes that broke OH3 database updates for a few weeks before 3.0.1.

Those issues have now been resolved.

1 Like

When trying to use this method i get this strange UI behavior that i have to write my associations ?
Compared to before. Where i only have to select the thing and select the endpoint.

I don’t use associations but i checked it with my devices and i can choose other nodes.

Either it is a bug in the binding or something is wrong with the database concerning your devices. Have a look at opensmarthouse.org

I’m logged into the Karaf console and I can see that the ZWave bundle is loaded, but my USB Z-Wave controller is premanently in “UNINTIALIZED” state after installing the 3.1.0-SNAPSHOT… Also, the Bundle shows “Installed”, but when I try to “start” the bundle is fails with an error:

Error starting bundle 294: Could not resolve module: org.openhab.binding.zwave [294]

Any advice?

This relates to the original problem in this thread how?
Start your own thread. It is much less confusing for the volunteers here.