[Solved] Openhab 1.8.3 error on runtime startup


When starting the Openhab 1.8.3 runtime, I get the same error repeating every 10 seconds. I’m trying to run the Openhab demo as a first attempt with Openhab. I’ve tried running the runtime using both start.sh and start_debug.sh and I’m always getting the same error. No log file is created in /opt/openhab. My hardware is a Odroid C2.

Java version:

openjdk version "1.8.0_111"
OpenJDK Runtime Environment (build 1.8.0_111-8u111-b14-2ubuntu0.16.04.2-b14)
OpenJDK 64-Bit Server VM (build 25.111-b14, mixed mode)

Error on CLI using start_debug.sh:

12:27:59.765 [ERROR] [.o.m.c.i.folder.FolderObserver:105  ] - An unexpected exception has occured
java.lang.NoClassDefFoundError: Could not initialize class org.eclipse.xtext.resource.XtextResourceSet$1
	at org.eclipse.xtext.resource.XtextResourceSet.getURIConverter(XtextResourceSet.java:170) ~[na:na]
	at org.eclipse.xtext.resource.XtextResourceSet.getResource(XtextResourceSet.java:136) ~[na:na]
	at org.eclipse.xtext.resource.SynchronizedXtextResourceSet.getResource(SynchronizedXtextResourceSet.java:23) ~[na:na]
	at org.openhab.model.core.internal.ModelRepositoryImpl.getResource(ModelRepositoryImpl.java:153) ~[na:na]
	at org.openhab.model.core.internal.ModelRepositoryImpl.addOrRefreshModel(ModelRepositoryImpl.java:71) ~[na:na]
	at org.openhab.model.core.internal.folder.FolderObserver.checkFolder(FolderObserver.java:142) ~[na:na]
	at org.openhab.model.core.internal.folder.FolderObserver.run(FolderObserver.java:99) ~[na:na]

Tell me if you need anything else!



Please change your Java version to Oracle.

I’m not sure to understand what this means… Can you provide a link, or instructions to download it?


try: http://www.wikihow.com/Install-Oracle-Java-JDK-on-Ubuntu-Linux
(google is your friend :))

I didn’t know about different vendor version.

Even with the oracle version I’m still getting the same error. I’ve installed the product:
Linux ARM 64 Hard Float ABI (jdk-8u121-linux-arm64-vfp-hflt.tar.gz)
from this link
since my odroid c2 is running a ARM 64bits.

Java version:

java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

Is there something I missed?


It seems that the problem was caused by wrong access permissions on /opt/openhab folder!


1 Like