[Solved] Openhab 2.1 does not know my sitemap

did the automatic update via openhabian-config as described in the github page.
However now my basic ui, classic ui and android app dont see my main application anymore. I see the sitemap file, i see the itemsfile but the UI’s donot. They do see another, not important sitemap though. My log file is just filled with the message it cannot load the unknown sitemap

2017-06-28 21:21:03.668 [INFO ] [est.sitemap.internal.SitemapResource] - Received HTTP GET request at '' for the unknown sitemap 'Huis'.
2017-06-28 21:21:03.668 [INFO ] [est.sitemap.internal.SitemapResource] - Received HTTP GET request at '' for the unknown sitemap 'Huis'.
2017-06-28 21:21:03.689 [INFO ] [est.sitemap.internal.SitemapResource] - Received HTTP GET request at '' for the unknown sitemap 'Huis'.
2017-06-28 21:21:03.691 [INFO ] [est.sitemap.internal.SitemapResource] - Received HTTP GET request at '' for the unknown sitemap 'Huis'.

In the Github page it is said the config files are now validated during runtime and that errors in the log file should be corrected. My eventslog however does not show any errors, so presuming this is indeed a runtime validation rejection, where do I even start ’ correcting’ a config file (item? sitemap?) that previously worked fine?
I rebooted several times with no effect

1 Like

Can you post the path to your file and maybe the contents of it?

Can you also monitor the logs while you do a touch on the file, it should reload than if something really fails it might give some hints.

I’m signing of now hope someone else can help you further :slight_smile:

Thank you Martin, the config files are in the specific folders that are created by openhabian, where they also where in the previous working situation and where the still loading sitemap is also present.

i keep monitoring the logs,. apparently it does check the itemsfile as it shows the ongoing changes. None of my logs shows errors, so i really have no idea

Edit: The only thing i could think of is that maybe I had forgotten a closing ‘}’ so i added one at the end. That was not it, but now the log file started to errors.

Turned out i had two errors:
I had used a single quote, where a double quote was necessary
I had used an opening ‘{’ where according to the log a closing ‘}’ was expected.
In all honesty i still dont understand why it should not be an opening character,but now it loads.

Can you share the configuration which gave you errors maybe others see the problem or maybe we should just create an issue.

I can do that, though I am not sure if it is reallu useful to put my sitemap here, but I will add it later today.
I was aware that if there were errors in the sitemap it would not load and I would have to check the openhab log to repair those errors.
In my case however, the log only mentioned it could not load the sitemap, no errors at all. Only when I started to make some changes, errors suddenly started to appear, which enabled me to pinpoint the problem. As said, the main issue was a quote and an opening ‘{’ character. Log told me that it expected a closing ‘}’ character.
Though I presumed i had to leave the opening character in place and just add the closing character before it, I decided to literally follow the advice and that worked.
when however I added the opening character too, as i was convinced i needed it to open a frame…sitemap refused to open and again no clarifying error in the log.
Anyway, will add sitemap later today

Why not using the Smarthome Designer? It will catch typos or errors during editing … :slight_smile:


I think I tried that one in a distant past but as a complete newbie then I think I just had no idea where to start and i had the feeling that with directly editing the files I had more control. But I will definitely give it a try again, especially now with rhe critical OH2.1
I must admit I find the nesting in the sitemap still a bit daunting so I try to stay away from it as much as possible and put most stuff in my itemsfile.
Thanks for pointing out the designer again. I had kinda forgotten about its existence

Martin, for completeness sake my code. For any newcomers, the problem is already solved.
Code is followed by a picture highligthing the problem area

sitemap Huis label="Home"
	Frame label="Home&Garden"{
		Group item=gGF label="Ground Floor" icon="groundfloor"  
		Group item=gFF label="First Floor" icon="firstfloor"
		Group item=gGA label="Garden" icon="tree" 
	//	Setpoint item=TimeSetpoint minValue=2 maxValue=8 step=1
//================================= new group==============================

Frame label="Settings"
Setpoint item=TimeSetpoint minValue=3 maxValue=8 step=1
//Text item=Shower1
Setpoint item=TimeSetpoint2 minValue=3 maxValue=8 step=1
//Text item=Shower2
//================================= new group===============================		
		Frame label="Weer"{
		Text item=Weather_Temperature valuecolor=[Weather_LastUpdate=="NULL"="lightgray",Weather_LastUpdate>90="lightgray",>25="orange",>15="green",>5="orange",<=5="blue"] 
   ///===========================met subgroup==============================
		Frame {
			Text item=Weather_Temp_Max valuecolor=[>25="orange",>15="green",>5="orange",<=5="blue"]
			Text item=Weather_Temp_Min valuecolor=[>25="orange",>15="green",>5="orange",<=5="blue"]
			Text item=Weather_LastUpdate visibility=[Weather_LastUpdate>30] valuecolor=[Weather_LastUpdate>120="orange", Weather_LastUpdate>300="red"]	
			Text item=Weather_Humidity valuecolor=[>45="orange",>35="green",>5="orange",<=5="blue"]	 label="Humidity" icon="humidity"
			Text item=Weather_Pressure valuecolor=[>1015="red",>1012="green",>900="orange",<=900="blue"] label="Airpressure" icon="pressure"			
			Text item=Condition
			Text item=Wind_Speed_Mph
     Text item=Wind_Direction
     Text item=Wind_Degree
     Text item=Wind_Gust_Mph
     Text item=Rain
     Text item=UV_Index	  valuecolor=[
				=="NULL"="#D3D3D3", // lightgray
				<3="#006400", // darkgreen
				<6="#FFD700", // gold
				<8="#FF8C00", // darkorange
				<11="#DC143C", // crimson (red)
				>=11="#4B0082" ] // indigo
    Text item=Station_Name
		 //     ==============en een andere subgroup==================
	Frame {
		Switch item=Weather_Chart_Period label="Period" icon="chart" mappings=[0="Hour", 1="Day", 2="Week"]
		Chart item=Weather_Chart period=h refresh=600 visibility=[Weather_Chart_Period==0, Weather_Chart_Period=="NULL"]
		Chart item=Weather_Chart period=D refresh=3600 visibility=[Weather_Chart_Period==1]
		Chart item=Weather_Chart period=W refresh=3600 visibility=[Weather_Chart_Period==2]
}  // -->>> This is were the problem WAS
Frame label="Sun&moon"{ //open2
Text item=CurrentDate  label="Sun [%1$tA, %1$td.%1$tm.%1$tY]" icon="sun_clouds"
{   //open3
Frame{   //open4
Text item=Sun_Elevation label="Height"
       Text item=Sun_Azimuth
       Text item=Sunrise_Time  label="Dawn"
       Text item=Sunset_Time  label="Sunset"
       Text item=Dierenriem label="Zodiac" icon="dierenriem"
       Text item=Moon_Elevation label="Maanhoogte"
       Text item=Moon_Azimuth label="Maan Azimuth"
       Text item=Moon_Illumination
       Text item=VolleMaan label="Full moon:" icon="vollemaan"
       Text item=NieuweMaan label="New moon:" icon="nieuwemaan"
       Text item=MaanFase label="Maanfase"
}  //sluit4
} //sluit2
}  //sluit1
//Text item=Volume label="Geluid" visibility=[Living_TV=ON]
//Setpoint item=Channel

1 Like

That’s what the Smarthome Designer would have shown: :sunglasses:

1 Like

Tnx, good to know. Now I spend most of my time counting accolades.
i installed Smarthome Designer on windows 10 this morning… would not open (no doubt a windows 10 problem). I will put it on Linux later today.

Still a bit surprised this particular error initially didnt report itself in openhab log, that happened only later when I started to mess with the file

You will need java 32Bit and the smarthome designer 32Bit (even on a 64Bit Win).
Don’t install the 0.9 designer version, it has some issues, grab the 0.8 version.

Hmm. will look into that., Thanks. I have other java apps working on my windows, but indeed I took the 64 bit home designer

If you are familiar with Visual Studio Code, you may take a look into that as an alternative:

Thanks, May give that a try too. I already wondered why when clicked my files wanted to open in Visual Studio :slight_smile:

works wel on Linux, cant get it to work on windows, not even the 32 bit version. too much of a hassle. I will use it on Linux

Had the same problem… one “}” to much… OH2.0 was not so sensitive to that. :grinning:

1 Like

:grin: the good old days