[SOLVED] Openhab 2.3 running problems

Hello all,
I have a Openhab 2.3 version running in a Debian 8 platform.
Until 2 months ago I had my Openhab 1.8.3 running smooth and decided :grimacing: to upgrade to 2.3, everithing went well with just a few bumps that where solved.
The issue that I bring is that the Openhab ramdomly (can take one day… one week …) stops the normal work; it still opens thru the web acess or the habdroid but the switches when acted dont change the icon state, graphics are not displayed and seems to me that rules are not activated.
Cheking the logs (openhab.log) all are ok without errors and if I try to restart the service (service openhab2 restart) it stays forever waiting.
Can someone help, this installation is controlling all my house and farm and when is hangs it gives me BIG problems.

Thanks in advance

It looks like you are running out of threads. “rules are not activated”
Have a look at this:

Do you have any rules with Thread::sleep?
Or any while loop? Or any long running actions like executeCommandLine/httpGetRequest?

Dear all.

Aftres some time having randomly this problem I reinstalled the Debian (upgraded it to 9) and installed all the other packages including OPENHAB and the problem until now didnt appeared yet.

1 Like