[SOLVED] OpenHAB 2 Update issue


since a few weeks i have an issue with updating my system. I am running a manual installation on an debian server. I am updating according to docs.openhab.org with renaming the “/opt/openhab” folder to an backup folder and unziping a new one. After that i copy conf and unserdata from the backup.

But although the binaries are up to date:

-rwxr-xr-x 1 root root 15989 Jan 21 12:35 karaf

i get this banner:

Build #688

First i thought it is some issue with the start script, but even if i start manually with start.sh or /runtime/bin/start i get the #688 banner.

Any ideas what i can further check?

Thanks, Jens

Hey @Jensen,
these instructions are not perfectly complete, some files in userdata need to be replaced. I’ve spent more efforts to update the package repository installation instructions. A path you should definitely consider!

If you still want to do a manual installation, please check the more complete instructions here: http://docs.openhab.org/installation/windows.html

One more detail: It was already discussed, that it would be great to have update scripts for zip-file based installations, served inside the zip. If you or whoever is reading this are experienced in bash/batch scripting and want to take that task on, let us know

Hi Thom,

thank you very much, i will consider changing to package repository.


Issue is solved. I moved to package repository.

1 Like

Wouldn’t that be a nice job for @xsnrg?


I did what is written in the Windows installation link to update to the current 2.0 Release and I failed. System was not running at all and stopped with an error. triede several times. Then I resored the backup.

What worked is to delete only the userdata/tmp and /cache, I left alone the other files.
Then overwrite the runtime folder with the new runtime.
This works fine. On the first start it seems not to load the sitemap, one restart and everything is fine.

I try to keep the script up to date with any changes nearly daily. (there have been a lot lately). As of yesterday, it is working again with the latest snapshot builds (2.1.0). It can be included with the distribution .zip if the powers that be desire it.

Thanks for the mention.