SOLVED: OpenHAB 3.4 KNX Binding can't reach bridge anymore after Synology DSM upgrade

I have been running OpenHAB in a docker container on my Synology for a while without any issues. I have been running the latest stable (3.4.0). The Syno is running in my DMZ, with my Smarthome components including the KNX-IP-Interfaces in a dedicated network segment. Routing and FW rules are set-up accordingly. This setup has been running for about two years without any issues.

Yesterday I took the latest upgrade on Syno’s DSM and since the update, OpenHAB can’t reach any of my two KNX-IP-Interfaces anymore:

12:03:26.090 [ERROR] [NXnet/IP Tunneling] - establishing connection failed, timeout connecting to control endpoint​ is the bridge (Gira X1); I have another I/f (MDT) in the same subnet, which shows exactly the same behavior if I reconfigure to use that one as bridge.

Both the docker host (Syno) and the container (OpenHAB) can reach the subnet without any issues (tested with ping, tracert). OpenHAB seems to work fine, too - just the bridge(s) seem unreachable.

I obviously did start/stop everything multiple times, uninstalled and re-installed the KNX binding, increased time-outs - no effect/change.

I have run out of ideas, especially since I didn’t really change anything than the OS of the Syno… Any tips appreciated.

Disclosure: Crossposted in German to the KNX-UF, too.

I managed to solve the issue by setting useNAT : true. However, I don’t really understand why this solves the problem :grinning:: I didn’t have this set before (the DSM upgrade), and I don’t think, that any NAT is in play here…