[Solved] openHab 3 UI suddenly shows "Overview not yet configured" and no click works

  • Platform information:
    • Hardware: Raspberry Pi 4 Model B Rev 1.4 8 GB, external SSD
    • OS: Pi Os Buster latest version
    • Java Runtime Environment: openjdk version “” 2020-11-04
    • openHAB version: 3.0.2 - Release Build


my openHab UI stopped working all of a sudden.
I was working on a custom widget when the UI stopped reacting to my mouse clicks.
I waited for a while and then, after there was still no reaction, I reloaded the page.

But now my Overview page is gone, it’s just “Overview not yet configured”.

And still no reaction when I try to click anything, doesn’t matter if I click on “Settings”, “Developer Tools”, my Profile or anything else: Nothing happens.

I checked my jsondb folder and there I can see, that all my configurations and custom widgets are still there and correct.

The UI also shows my already configured pages, but here the same, if I click on them nothing happens.

The overview page and all other pages worked before.
Habpanel is still working and all things and items are still there.

What I have tried already:

  • Reinstall openhab via openhabian-config
  • Restart openhab
  • Reboot system

Very strange, maybe someone can help me what to check or do next.


When I try to use the url directly, e.g. …:8080/profile, I get “Not found”.
Also the other UIs, like CometVisu and Habpanel, are not shown on the right side, the sidepanel is just empty…

Try clearing your browser cache? I know Chrome especially caches aggressively

Thx, I tried, but that doesn’t help.
I also tried in Firefox, which I didn’t use at all for openhab 'til now, but it’s the same with it.

Sounds like you may have incorporated a fatal error into your widget definition which is causing the whole UI to fail to load. You probably need to restore one of the automatic uicomponents_ui_page.json backups in the userdata/jsondb/backup folder. If you think that will lose you too much work and you know where the error might be you can try to just edit the uicomponents_ui_page.json directly but don’t do that without reading the Editing the JSONDB, a last resort of the following post:

1 Like

That’s a good advice, I will try that.
Right now I uninstalled openhab and I now reinstall it and restore it from backup.
If then the error still appears I will try your solution.
Thx :slight_smile:

Hi JustinG,

You where right, that did the trick.
My custom widget was causing the complete UI to stop working.
These where my steps to get back to production again:

  • Stoping openhab
  • Clean cache
  • Edit uicomponents_ui_widget.json and deleted the custom widget declaration from file
  • Edit uicomponents_ui_page.json and deleted the widget from config
  • Restart openhab

After that I created my custom widget again without the last changes and everything is working again.

Thx very much for your help

1 Like