[SOLVED] openHAB Beta Problems with Android9 and webview url

Hello Community,
i’ve got problems with Android 9 on my Sony
ZX2. There is a webview url with my cameraserver.
I’m using MotionEyeOS. The images start loading
but nothing more. The solution is to deinstall
Android System WebView. I hope you can
handle this. Thanks for the greatful openHAB
software and the great community.


Sorry but its forbidden for me to upload more than one

Welcome to the openHAB Community :heart:

I think you might want to post this to the github https://github.com/openhab/openhab-android
Since it’s directly related the Android App and not openHAB in general. :slight_smile:

Yes i think so too, but openHAB in Google Playstore
says: post it here. :wink:

And i think, it helps some users like me. First we
look here to solve problems.

Do you have some other WebView instead? The one by Google from the Play Store?

I usually post the link to the forum in Google Play Store comments, because IMO the forum is a better place for new users.

Well, there’s the “Android App” category, so it’s perfectly fine here.

1 Like

No chance. I played with delveloper options (no root) and with chrome and system webview. It only works if i deinstall webview/ Chrome (old version) . I also played with other webview apps, also no chance. Webview works only in older versions with your beta, i think google change something, chrome has the same behaviour.

In this case I don’t think we can do something. Can you try to extract the image url and use an image item?

Solved! Now I upgraded to Android 10…everthing is fine now.