[SOLVED] openHAB Cloud expose items, I need guidance

Thanks Rich

the number 581 is a defect. it do not reflect the accurate number set in the file (20)

  • I have commented all the file

  • unselect paper ui

  • delete all the Items configured to be shared in PaperUI (i.e. make them no longer listed in the cloud connector config, don’t delete the actual Items).

  • Stop Server

  • Find and delete /var/lib/openhab2/org/openhab/openhabcloud.conf

  • Delete cache and temp

  • Start server

  • Select to expose 7 items in the paperui

  • from a sitemap, Update from OFF to ON and ON to OFF, the exposed items

    Switch item=GlobalScene mappings=[ON=“All On”,OFF=“All Off”]
    Switch item=iftt_Switch mappings=[ON=“All On”,OFF=“All Off”]
    Switch item=IFTTT_Calendar mappings=[ON=“All On”,OFF=“All Off”]
    Switch item=Shabbat_Switch mappings=[ON=“All On”,OFF=“All Off”]
    Switch item=TelegramInput mappings=[ON=“All On”,OFF=“All Off”]
    Switch item=VoiceCommand mappings=[ON=“All On”,OFF=“All Off”]
    Switch item=VoiceToSpeak mappings=[ON=“All On”,OFF=“All Off”]
    Switch item=irobot mappings=[ON=“All On”,OFF=“All Off”]

Some items are defined as string items but displayed as a switch to change easily the state.

  • Wait 30 minutes

Still do not work :frowning:

a new recurring error in my log
`2019-01-29 09:08:13.418 [WARN ] [io.openhabcloud.internal.CloudClient] - Jetty request 2585025 failed: null

2019-01-29 09:08:13.424 [WARN ] [io.openhabcloud.internal.CloudClient] - Response Failure: null

2019-01-29 09:08:43.800 [ERROR] [ersey.server.ServerRuntime$Responder] - An I/O error has occurred while writing a response message entity to the container output stream.

org.glassfish.jersey.server.internal.process.MappableException: org.eclipse.jetty.io.EofException

at org.glassfish.jersey.server.internal.MappableExceptionWrapperInterceptor.aroundWriteTo(MappableExceptionWrapperInterceptor.java:92) ~[?:?]

at org.glassfish.jersey.message.internal.WriterInterceptorExecutor.proceed(WriterInterceptorExecutor.java:162) ~[171:org.glassfish.jersey.core.jersey-common:2.22.2]

at org.glassfish.jersey.message.internal.MessageBodyFactory.writeTo(MessageBodyFactory.java:1130) ~[171:org.glassfish.jersey.core.jersey-common:2.22.2]

at org.glassfish.jersey.server.ServerRuntime$Responder.writeResponse(ServerRuntime.java:711) [172:org.glassfish.jersey.core.jersey-server:2.22.2]

at org.glassfish.jersey.server.ServerRuntime$Responder.processResponse(ServerRuntime.java:444) [172:org.glassfish.jersey.core.jersey-server:2.22.2]

at org.glassfish.jersey.server.ServerRuntime$Responder.process(ServerRuntime.java:434) [172:org.glassfish.jersey.core.jersey-server:2.22.2]

at org.glassfish.jersey.server.ServerRuntime$2.run(ServerRuntime.java:329) [172:org.glassfish.jersey.core.jersey-server:2.22.2]

at org.glassfish.jersey.internal.Errors$1.call(Errors.java:271) [171:org.glassfish.jersey.core.jersey-common:2.22.2]

at org.glassfish.jersey.internal.Errors$1.call(Errors.java:267) [171:org.glassfish.jersey.core.jersey-common:2.22.2]`

@rlkoshak, it do not work yet

in spite that the expose is well stored

What i am missing?

i have also uninstalled and reinstalled the openhabcloud Binding without sucsess

I don’t know. The steps you took are the ones I would recommend.

It is encouraging that the list matches between PaperUI and the cfg file. But the error does show there is some sort of communication problem between OH and myopenhab.org.

All I can say is that others are doing this successfully. I can’t say what is going wrong for your setup.

1 Like

I renounced. I restore an image one month old

Is it solved? I am facing this same issue?

Hi @Sudipta_Ghorui. At the moment, you can’t expose new items to PaperUI. This had to be turned off due to database issues that were crashing myopenhab.org.

If your goal was to use a system like IFTTT, then you unfortunately won’t have any luck at the moment. However, you shouldn’t need to expose items via PaperUI for Alexa or Google Assistant to work, since they use tags in the item definitions.

Thanks @rpwong for the quick response.
I got it. No problem I can leave without IFTTT. I was just wondering if I am doing anything wrong.

Actually, you can integrate OH with IFTTT without exposing Items using the Webhooks channels. IFTTT can both send (through myopenhab.org) and receive HTTP calls . You will have to use basic auth in the URL for the calls to myopenhab.org though.

as I’m facing the same issue: Is it planned to be reactivated again in the future? If so, will it be published in this thread?
Thanks for your help and best regards

Also, @wsd33904 just wrote this post:

How To: Integrate Custom openHAB Cloud with IFTTT

It will probably be reactivated, but only if/when the experts can figure out how to prevent it from killing myopenhab. It’ll likely be discussed in the “Myopenhab not reachable” thread linked above, so that’s the one to follow.

Is there any progress on this?
My IFTTT applets also don’t work anymore.


I’ve also had the same problem, and I was using almost a year old nightly because of this, but, few days ago I’ve updated OH to the latest nightly, and IFTTT applets seams to work with it. Maybe you could try updating and see if yours are working too.

Best regards,

Hi, thank you for your answer.
Still some questions

  • I understood that this feature was disabled on cloud level and not in the openhab instance?
  • are these nightly builds stable enough to use in my house?


It depends. When updating to the latest SNAPSHOT you are updating to code that has just been merged and has not yet seen wide testing. So any given upgrade may break your particular configuration. But once installed, if nothing breaks, they run as stably as the milestones and the releases. To the stability of the snapshots really depends on how often you upgrade.


Now I’m really confused. I was using february/march nightly (not sure of the exact build) and IFTTT worked without problems. After trying to update to August nightly (again, not sure exactly) IFTTT stopped working. After reverting to the version I’ve used previously, it worked again. If it was disabled at cloud level, why did it work with older version?

Best regards,

Is it than possible that this is working by just using a snapshot version of Openhab?

No, because, like you asked and I confirmed, the change was made on the cloud server. It doesn’t matter what you do to your openHAB. I cannot explain davorf’s experience. But it has always been the case that if you set up exposed Items before the feature was turned off, those Items would continue to work.

Is it correct that the features only work in one direction?
My Openhab Item is a “IF THIS” condition and should trigger another IFTTT service but this isn’t working anymore.

Is there a chance that IFTTT will be “turned on” again at the stable 2.5 release in december?

There is no word on when this will be turned back on. The problem is with the cloud server, not openHAB, so it is unlikely that any fix will be tied to the openHAB release.

And is it correct that the features only work in one direction?
Like mentioned before, my Openhab Item is a “IF THIS” condition and should trigger another IFTTT service but this isn’t working anymore.