[SOLVED] openhab.command.refreshEntry

Hello community,
I am new here and newcomers to OpenHAB.

I put my system on a Raspi 4.
Openhabian installed as an image and currently use the homematic binding. That works perfect!
Now I wanted to set up the VS code. I have mounted the folder openHAB-conf as a network drive
and can see the folders in VS code.

If I want to synchronize the things now, I get the following error:
command ‘openhab.command.refreshEntry’ not found

I’ve already tried to uninstall the VS code and reinstalled, but to no avail.

Since I am absolutely new to the field, I hope someone can help me.
Thank you so much!

Did you reinstall it from the marketplace or by downloading the vsix file from GitHub?

Hello Jerome,
I only used the installation from the marketplace. Since the error occurred. Then I did the installation with vsix from GitHub. Unfortunately the mistake is here as well.

I have uninstalled and reinstalled Visual Studio code from my machine. Then set up the OpenHAB extension using the vsix file.
Unfortunately that did not bring the success. The error still exists:
command 'openhab.command.refreshEntry' not found

Can someone help me with the problem?
The machine on which Visual Studio Code is installed runs on Windows 7 Professional 64-bit.
The OpenHAB is installed on a Raspberry 4 with the Openhabian system.

Thank you so much!

unfortunately, i went through all the steps as violine did (uninstall, install latest extension from vsix) and I am still at the same point with openhab.command.refreshEntry while trying to sync things or items. As an Output on openhab Server I receive: [Error - 22:20:27] Connection to server is erroring. Shutting down server.

I use raspi3 with Raspian and Win 10 64bit.
Appriciate any support on that.
Thx JD

Did you also try the latest Beta Extension?
Can be found here in this forum category.

I am still unsure what goes wrong sometimes during install of the extension.
But the new beta is based on an improved build system.

I downloaded the latest one openHAB VS Code Extension 0.5.1 from github…

Then you should definitely try the beta linked above.

Also I thought that maybe something corrupted is still present in Vscode even when one uninstalls an extension through the UI.

You could try to manually remove the extension.
It’s described here.

Hi Jerome,
many thanks for fast reply. I checked the recommended beta and have general problem after installing and rebooting VSC. See the screenshots…


Update: removing extensions with rmdir %USERPROFILE%\.vscode\extensions /s did not helped . :frowning:

did you solve the problem?

Hey Jacek,

Basically this looks good.
The two shown notifications are known (and already solved) issues that have no connection to the command not found issue.
Please read the beta thread. We have talked about the notifications over there.

Does the refreshEntry message still appear?

Hi Jerome,
I do not think it is a problem of the VSC an its plugins. I have two PCs and one openhabian 2.4.0-1 on RP3.
Yesterday I I made an update of the opehabian with sudo openhabian-config. Than I installed VSC from scratch on new PC, when all problems occurred. Today morning I launched my old pc with previously working VSC and OpenHab 0.5.1 plugin and discovered the same problems.
It is not the problem of the plugin but something went wrong after updating openHabian.


Ps. System reboot did not solve the problem

Hey @wiewior,

Usually an openhabian update shouldn’t affect the extension in the way the problems are occuring here.
We are communicating with the openhab environment only through lsp server and rest api.
A “command” (especially when it is not found) is far beyond starting a connection from vscode to openhab.

The problem occurred with a newly installed Raspi 4. Since the error could not be fixed, I reinstalled the Raspi. After that the error did not occur anymore. I have also uninstalled VS code and deleted all files that generate VS code.
After that, the error did not occur again.

I’ve updated Openhab to 2.5 hoping to solve the problem with VSC connection.I really like this plugin and do not want to give up without solution :wink: Unfortunately openhab updates and VCS updates did not solve my issues. I am just wondering if i could get some logs captured to investigate the issue.

I do not want to re-install the system. It is linux so we can fix it more efficiently than win for example :wink:
Uninstalling VSC did not resolve my problem.

I don’t think that the raspi reinstall did solve the problem in his case.

Did uninstall the extension and/or vscode completely?
Did you remove possible left over data from the user folder like decribed above?

I will come back with results on this what you proposed. I did the steps you refer to. I uninstalled beta VS I removed extension manually as well. I did the same on two pcs. on both I have the same problem.
But honestly I will check this again and then come back…

do you have any new release of the extension? Beta link does not exist anymore “Build not found”
What is the latest build I could try out?

I uninstalled VS as well as removed extensions manually as described in previous posts
Reboot the PC
Install VS newly
Install latest openhab extension 0.7.0
After while pop up comes and can not get the extension working :frowning: :

When this message appears the extension -is- basically working and the refresh entry problem is disappeared.

The shown error message is related to remote Language server.
Are you using openHAB 2.4 currently?
There is a server side lsp problem that has been solved in oh 2.5 for this.

No, I use 2.5.1 version of the openhabian.
If it works, how can I list and insert items from the thing? Maybe I am overseeing sth.?

OK I solved problem with the connection. In the extension settings I had to update “openhab.host”: in settings.json

    "openhab.host": "oh2",
    "window.zoomLevel": -1,
    "explorer.confirmDelete": false,
    "workbench.iconTheme": "openhab",
    "openhab.useRestApi": true,

There is last thing I am fighting with. How to see openhab things and the icon to import items- I can not see that option

openhab thigs and items three missing: