[SOLVED] openhab.command.refreshEntry

Hello All :stuck_out_tongue_winking_eye: .

I would like to try to edit the sitemap with VS Code.
I have the extension installed, but I get this error message:

command ‘openhab.command.refreshEntry’ not found

So i deinstall VS Code, remove the extension path from CurrentUser, restart the PC, restart my Raspy but nothing works.

I am grateful for your help !

Platform information:

  • Hardware: 1.4GHz 64-bit quad-core Broadcom Arm Cortex A53/ 1GB RAM/ 8GB Storage
  • OS: Raspbian Stretch Lite
  • Java Runtime Environment: Java8JDK
  • openHAB version: 2.4.0 BUILD

I have found a solution that works for me:

Sounds weird, but it works for me.

Tested it with VS Code & VS Code Insiders

We had this problem already some time ago.

Starting at this post and the following ones.

SOlution was similar to yours.


A fresh extension install, from .vsix file directly.
My guess would be, that this is one extremly rare cases where something with vscode ot the extension download is wrong and corrupts the extension or its files.

1 Like

Hello community,
I am new here and newcomers to OpenHAB.

I put my system on a Raspi 4.
Openhabian installed as an image and currently use the homematic binding. That works perfect!
Now I wanted to set up the VS code. I have mounted the folder openHAB-conf as a network drive
and can see the folders in VS code.

If I want to synchronize the things now, I get the following error:
command ‘openhab.command.refreshEntry’ not found

I’ve already tried to uninstall the VS code and reinstalled, but to no avail.

Since I am absolutely new to the field, I hope someone can help me.
Thank you so much!
violine

Did you reinstall it from the marketplace or by downloading the vsix file from GitHub?

Hello Jerome,
I only used the installation from the marketplace. Since the error occurred. Then I did the installation with vsix from GitHub. Unfortunately the mistake is here as well.

Hi,
I have uninstalled and reinstalled Visual Studio code from my machine. Then set up the OpenHAB extension using the vsix file.
Unfortunately that did not bring the success. The error still exists:
command 'openhab.command.refreshEntry' not found

Can someone help me with the problem?
The machine on which Visual Studio Code is installed runs on Windows 7 Professional 64-bit.
The OpenHAB is installed on a Raspberry 4 with the Openhabian system.

Thank you so much!