[SOLVED] openHAB dashboard insists on requesting Location Service in Windows 10

Location Service is disabled on my Windows 10 PC.
Settings > Privacy > Location > Location service > Off

Every time I access openHAB’s dashboard, using MS Edge, it insists on accessing the PC’s Location Service. How do I configure openHAB to stop requesting it?

Fill in your lat/lon in Configuration > System > Regional Settings or press “Settings” and tell your browser t ignore future requests.

Thanks Rich, that did the trick (Regional Settings). However, I am positive I filled out all fields in Regional Settings when I installed openHAB just a few days ago. When I checked it now, all fields were blank. I can only assume I forgot to click the Save button and all my entries were lost (because I doubt openHAB ‘forgot’ them).

I’m going to keep an eye on it. Although the Location field definitely shows my lat and lon, the following two lines in openHAB.log give me pause (Location set to null?!?):

2018-01-24 23:04:51.457 [WARN ] [.core.internal.i18n.I18nProviderImpl] - Could not set new location, keeping old one: 
2018-01-24 23:04:51.466 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to en_CA, Location set to null, Time zone set to America/Montreal