[SOLVED] openHAB-Distribution [Jenkins] RSS-Feed: <updated> and <published> entries are empty

Tags: #<Tag:0x00007f746485cca0> #<Tag:0x00007f746485cac0> #<Tag:0x00007f746485c890>

Hello Folks,

I use the following RSS feed to “openHAB-Distribution” on “Jenkins” for more than 2 years now:

https://ci.openhab.org/job/openHAB-Distribution/rssAll

But since a few weeks, the RSS Feed “rssAll” is wrong!

The following entries are OK:

<title>openHAB-Distribution all builds</title>
<entry><title>openHAB-Distribution #1676 (Stabil)</title>

The following entries are EMPTY:
(normally the entries should be like this:)

<updated>2019-09-01T18:15:00Z</updated>
<published>2019-09-01T18:15:00Z</published>

.

The field “updated” is MANDATORY and field “published” is empty, see Atom definition, here.

Who is responsible for configuring RSS Feed on Jenkins build server?

Perhaps that URL was no longer accurate with the move to the new build system? Since they have now released a testing build it would make sense to remove the old system.
Just a guess. @Kai may have more insights.

The answer is simple: Nobody maintains/configures the RSS feed, this is a standard feature of Jenkins.
I hence suspect that it might be a change/regression in Jenkins. We currently run version 2.176.2, so you might want to check their issue tracker…

2 Likes

Thanks for the hint! :slight_smile:

OK, it seems to be an issue reported:

https://issues.jenkins-ci.org/browse/JENKINS-58595?workflowName=JNJira+%2B+In-Review&stepId=4

With exactly my question:

https://issues.jenkins-ci.org/browse/JENKINS-58595?focusedCommentId=372493&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-372493

Let’s wait and see…

Looks indeed like it - so it should hopefully be solved with one of the next updates (I do them regularly).

1 Like

@Kai

.
It has long been merged. See the blue mark.
.

.

Do you execute LTS (Long-Term Support) releases (–> are chosen every 12 weeks)
or weekly updates (a new release is produced weekly to deliver bug fixes and features to users and plugin developers.)?
.

.
.
It’s still on 2.176.3
.
.
EDIT: Ok, I see, you use the LTS and it’s not in there!
.
.


.

I’m going to observe LTS Changelog now. Then I will recognize when issue 58595 will be merged there…

Correct!

Since it is LTS, can they provide support by providing patch for this issue? :wink:

Yes, but only in the long term :stuck_out_tongue_winking_eye: .

2 Likes

There’s now a new LTS release (2.190.1) with the fix @Kai :

2 Likes

Fix for 58595 (included in 59167) seems to be included LTS 2.190.1 :slight_smile:

@Kai
@wborn

The 2.190.1 is online. It solved my problem.

Thanks @kai :slight_smile:

4 Likes

That’s good news and thanks @Kai! :slight_smile:

You’re welcome :slight_smile: .

1 Like