SOLVED: Openhab Forum: Issues to login via GitHub & to register new user

Tags: #<Tag:0x00007f6180b4ba98> #<Tag:0x00007f6180b4abe8> #<Tag:0x00007f6180b49568>

Hi

First of all: I had to register a new user account in order to post this topic.

What happened?
I am used to authenticate to this forum via my GitHub account. This was working for years and stopped approx. last week.
When I try to login via GitHub the forum responds
“[…] there was an error authorizing your account. Perhaps you did not approve authorization?”

So I did return to GitHub and checked “Authorized OAuth Apps” and “Discourse” is listed as an authorized app.
I did afterwards revoke authorization for “Discourse” and authorized it again on Github via login to this forum. But it didn’t work out. Same issue.

To be able to report this problem here I registered a new forum account (native Discourse). During the account provisioning a similar issue turned up:

I received the “[openHAB] Confirm your new account…” email. I clicked on the included link to confirm and were forwarded to a page saying something like “Problem with authorization” (sorry no screenshot or exact wording).

So, it seems there are some issues with user login and new user registration with this Discourse instance.

Any suggestions or help?

Thanks, Bodo

I have noticed random issues with my iPhone. I use the Google login.
I hit login with Google, it fails, and I hit login again and it directly works.

Perhaps there is a timeout that is set too aggressively so the forum times out.

Thanks for the hint. I tried multiple hits on login on the iPhone as well and it worked. Unfortunately no luck with my desktop browser…

@ysc I am not sure, if you are the right addressee for this issue. If not I am sorry. If so, do you mind to look into this? Thanks a lot, Bodo

Sorry for the delay (I am in holidays :wink: - @digitaldan @Kai are you aware of this, is it a known issue atm?

1 Like

Hmm, i have not heard of this happening before. I tried logging out and back in a few times using my Github account and have not been able to reproduce. Strange.

I use Google on my iPhone 6 with the latest iOS, using the builtin Safari browser.

i click Login & then Google.
I get the error like the forum is not authorized but with a double top header. (as shown above)
Clicking either Login or Sign Up logs you in directly the with the expected single header at the top.

Note that on the double header only the lower one has the login buttons. Since the other screen shot was from a Mac perhaps this is a Safari incompatibility.

Just tried Firefox on my Mac. Same story.
To track down the issue, I removed again OAuth authorization at GitHub for openhab-bot and started with a new trial from the beginning:

  1. After clicking “Login with Github”

  2. After clicking “Authorize openhab-bot”

  3. Checking if openhab-bot is really authorized at GitHub
    Interesting: See the “Never used”. Could it be that there is no authentication request submitted by the forum to GitHub?

Cheers,
Bodo

P.S.: I had to combine the three screenshots into one file, since with this forum account I am a “new” users, who is only allowed to post one image . :wink: Pls click on the image to see all three screenshots…

1 Like

I had updated the Discourse software to version 2.4.0.beta2 around that time - maybe they had some regression? I couldn’t see anything obvious in their commit history, though.

I do not want to make too many people busy with this issue. To workaround it:

Would it be possible to migrate a Discourse-via-GitHub-account into a native Discourse account? Would prefer that. I should have created a native account straight from the beginning. :wink:

@Kai I have a quick curiosity question. Why run a beta version in a production environment?

Good question, I cannot see any obvious way to do so, but looking at your profile (bodomenke), I also do not see anything that says that it is tied to Github auth. It actually also claims that you were seen 2 days ago, so you must have successfully logged in again? What happens if you login with that user through the normal login screen? Can you ask to reset the password or is there no such option for that account?

It’s the official recommendation.

1 Like

Thanks. Sorry about the phone spellcheck.

Reason is, that I had still an active session with bodomenke on my iPhone. So I logged out on the iPhone and logged in, which brought up the same problem. Difference: After the error message, I tapped again on login and it worked. Same behavior that @Bruce_Osborne described.
Once I was logged in I removed in my Discourse profile the link to the GitHub profile. Was hoping that this could heal the issue.
Result: Authorization issue/message didn’t change, but I could not succeed with another tap on Login (as before).
BTW: On my Mac Safari the second click on Login after the authorization error never succeeded.

Good question. I will try this next and report back.

Hooray @Kai, “Forget password” worked out!

Seems that I have “migrated” my account by this to a native Discourse account. Very nice! Even if the root cause is not solved by this yet (I don’t care honestly), I am more that happy with this solution.

From your POV: Shall I mark this issue as solved, even in the RC is still unknown?

Glad to hear that you can log in again!
Yes, I’d think you can mark it as solved as this is a workaround we can do. The RC is most likely in the Discourse software, which we cannot change (and hope that it’ll be fixed in a future version).

2 Likes