(solved) Openhab <-> mysensors only receiving but not sending

Dear community,

hope you can help.

I’m on OH 2.5 and using mysensors binding

Configuration of Bridge

        Bridge mysensors:bridge-eth:mysgw [ ipAddress="localhost", tcpPort=5003 ] {
        humidity    Schrank_120_0       [ nodeId=120, childId=0, smartSleep=true, requestAck=true ]
        light       STV1                [    nodeId=8, childId=1 ]


Number     Schrank_Luftfeuchte         "Luftfeuchte Schrank [%.1f %%]"	<temperature> (mys_Luft) {channel="mysensors:humidity:mysgw:Schrank_120_0:hum"}
Switch Schalter  (mys_IR)  {channel="mysensors:light:mysgw:STV1:status"}

I can see sending and receiving in the logs working smoothly. Problem is that the sending command never appears in mysensors (MYSGW Log).
I have added sudo usermod -a -G dialout openhab as described in the binding docs. But no success…

Anyone any idea what is missing - how to debug this further?


Try adding openhab to tty group as well.

If your using openhabian the openhabian-config tool will handle the permissions for you. :wink:

thats it! Thanks a lot!

Glad to help. :+1:

@mm1804: Please click the square box on post that provided the solution to mark topic as solved.