[Solved] Openhab not initialised on raspberry Pi3 B

Good morning,
I am newbie &had downloaded openhab stable image for raspberry Pi.
I flesh image on 32GB as card using etcher.
Then I had put it on my Raspberry Pi 3B.
I had connected LAN cable in to PI for internet connection.
Then I had powered up RPI. Keep it running over night for to complete all installation process.
Second day i checked IP of PI from router then open putty on my laptop & Connected to Pi using user & password “openhabian” & I get error as shown in image.
Error :- initial setup exiting with error

What is wrong with my setup???

well… it seems that your rPi cannot reach the internet.

can you ssh into it (using putty) and try some internet connectivity tests?

sudo su
ip r
ping www.cnn.com
1 Like

My laptop Connected with smart router & internet is working on it.
I also got up of Pi from my router.
I use putty to connect RPI using username/password “openhabian”

As soon as I entered username & password I got screen as in image.

I am not able to apply any command from this screen.

which openHABian release are you using? v1.4.1 from here:

If yes, for ssh connection, the username is openhabian and the password is openhabian

Read: https://www.openhab.org/docs/installation/openhabian.html#raspberry-pi

If it still doesn’t work: I would start again from scratch (download image again and reflash your SD Card)

1 Like

Oh sorry. It’s typing mistake in above reply.
I actually used openhabian as password & username.

Finally problem resolved.
I think internet connection is not working previously.
I just reviewed RPI & waiting for couple of hours.
Now I can successfully logged in to Openhab.
Thanks to all for support.

1 Like

Thanks for marking the post that provided the solution.:+1:

I edited the title to start with Solved.


1 Like