[SOLVED] Openhab + Raspi 3+ + Zigbee + Hue Bulb + Aqara Cube

  • Platform information:
    • Hardware: Raspberry Pi 3+
    • OS: Raspbian Stretch
    • Java Runtime Environment: Zulu newest
    • openHAB version: 2.3
  • Issue of the topic: Cannot Bind Hue Bulb and Aqara Cube ( No bridges just Zigbee Link)
  • Please post configurations (if applicable): Cant post as I just installed the Bindings and wanted to add the Things but cant find them


so I installed Openhab 2.3 on a raspberry with my Zigbee in place. I can add the Hue Bulb in de deConz software and control it, so the Zigbee is working as expected.
When I open Openhab and after installing the bindings für Xiaomi, Zigbee and Hue I cannot find my devices, when I start an automatic search.
I didn’t configure anything yet in Openhab as after searching the community I could not find a reliable Tutorial with step-by-step what I need to do to get them working. I am really frustrated right now and it is probably a config thing I need to do before binding my things. I appreciate any help in this mater and can provide more information if needed.

Thank you very much.

Are you using the hue hub hub?

If not then the hue binding won’t work… the hue binding is for communicating with the hue hub. Pretty sure Xioma the same but not certain.

This is first question, I am not familiar with some of the other things in your setup to answer further.

you are trying to use the HUE api exposed by the deCONZ-software - right?

If so, this tutorial I’ve made some day may help:

1 Like

As I said, I don’t use any hubs, just the Zigbee module for the raspberry.

Hey, thank you for your tutorial will try it when I am home tonight. Any help besides the hue for the Aqara, that would be nice to get working.
I will also probably make a tutorial Video with my brother on his channel how to do the bindings etc as it is a nice setup to have. After the Hue is working I want to implement my Ambilight around my TV for some more affects.

Here’s another Option if you want to take a look.

1 Like

Thank you for your tutorial. Now I can control my light :slight_smile:

I updated my deconz to 2.05.41 and it said on the github page that now the cube is also supported with the new firmware but I cant get that to work :frowning: any ideas on that?

To be honest, I do not use deCONZ at all :wink: But I had all the required components laying around so I did the test setup and the tutorial just for curiosity to see how it works :wink:
(and to help @tropisch and others on the forum of course) Personally I use the native zigbee binding with a TI CC2531 usb stick…

Just a guess: @chris mentioned one day in relation to the Xiaomi zigbee devices that they turn to sleep very quickly. For the zigbee binding it is essential to keep Xiaomi’s awake until the full discovery of it has completed. This worked for me for the Xiaomi zigbee temp/hum/pressure sensors. It’s probably the same for the Cube.

Means: If you have a peering button on it, press it every 5 to 7 seconds during the discovery.

I just have a reset button, but that is probably the same. But won’t that just show the cube in deconz and not in openhab2 where I want it to be?
Also I would like to use raspbee without deconz if possible and use the zigbee binding in oh2 or the hue bridge binding. :frowning:

This is not possible (yet). Chris has the support for the Conbee/Raspbee ready but want to get it more mature before merging it into the zigbee binding. Until this, the only way I know about is to use deCONZ as bridge which mimics a HUE hub and use the HUE binding to access it.

Ok but I still dont get it. Why is it working for you and not for me? Am I on the to latest beta? I could add a normal Switch and the cube but they dont do anything in Phoscon and in Openhab they dont even show up. When I dimm the light directly in the webgui or the phone app in phoscon or openhab, it works just the switches dont. I have the version 2.05.41 beta installed. Is that to new?
raspbee switch

Maybe you have to peer them somehow to the bulbs to control them (in addiation to get included into the gateway’s zigbee network). I had a similar issue with a Philips living colors remote to control bulbs.

I think, the HUE binding can just discover what is been exposed by the deCONZ/Phoscon-HUE-api. Since you can control your bulbs via openHAB the authentication between openHAB-HUE-binding and the deCONZ/Phoscon-gateway seems valid. Every new zigbee node exposed by the api on the Phoscon should be appearing in the openHAB inbox almost instantly. If this is not the case either the device is probably not exposed by the Phoscon or the type of the device is not known (not supported) by the HUE binding.

Yes I know, this is very likely not what you wanted to hear :wink:

You may wait for the ConBEE/RaspBEE driver finally been merged by @chris into the zigbee binding.

Once this is done, the zigbee binding can use your RaspBEE directly and discover all the functions (better: supported/implemented “zigbee clusters”) of your zigbee nodes and make these available to openHAB. If the implemented functions conform to the zigbee standards this may work immediately. If it not works instantly, ask @chris in the zigbee thread for help. He is quite responsive to questions and had helped a lot in the past with squeezing new stuff into the binding or with just giving helpful advices :wink:

1 Like

Ok, I suppose I have to wait. Any estimation when it will be released? I want to start as soon as possible with smarting up my home :slight_smile:
I really hoped I could solve it with deconz etc :frowning:

Thank anyways for your help.

Have you been able to register your Cubes with deconz?

Also have a look here.

Hi, I could pair my cube but dont get any status updates :frowning:

I read in a pm that I have to use another zigbee module (TI etc)