[SOLVED] OpenHAB service fails to start

Cheerio! I’m happy to be a new OpenHAB user.

Unfortunately I am struggeling with my first startup. Here some information on my system first:

  • Platform information:
    • Hardware: Intel® Core™ i7 64-bit /16GB/256 GB
    • OS: Ubuntu 18.04
    • Java Runtime Environment: openjdk version “15.0.1”
    • openHAB version: openHAB2

The problem is that my first startup of OpenHAB does not work.

Running the service:

sudo systemctl start openhab2.service

ends in

Job for openhab2.service failed because the control process exited with error code.
See "systemctl status openhab2.service" and "journalctl -xe" for details.

Checking this from my perspective the karaf service is the problem:

   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/openhab2.service.d
   Active: activating (start-post) (Result: exit-code) since Wed 2020-11-18 16:22:34 CET; 59s ago
     Docs: https://www.openhab.org/docs/
  Process: 26676 ExecStop=/usr/share/openhab2/runtime/bin/karaf stop (code=exited, status=3)
  Process: 26675 ExecStartPost=/bin/bash -c /usr/bin/find ${OPENHAB_CONF} -name "*.x" -exec /usr/bin/rename.ul .x .rules {} \; (code=exited, status=0/SUCCESS)
  Process: 26838 ExecStart=/usr/share/openhab2/runtime/bin/karaf ${OPENHAB_STARTMODE} (code=exited, status=255)
  Process: 26837 ExecStartPre=/bin/bash -c /usr/bin/find ${OPENHAB_CONF} -name "*.rules" -exec /usr/bin/rename.ul .rules .x {} \; (code=exited, status=0/SUCCESS)
 Main PID: 26838 (code=exited, status=255); Control PID: 26841 (sleep)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/openhab2.service
           └─26841 /bin/sleep 120

Nov 18 16:22:34 lenovo systemd[1]: Starting openHAB2 instance, reachable at http://lenovo:8080...
Nov 18 16:22:34 lenovo karaf[26838]: Error occurred while checking the system module.
Nov 18 16:22:34 lenovo systemd[1]: openhab2.service: Main process exited, code=exited, status=255/n/a

Any ideas on how to solve this?

Please read the prerequisits, openHAB 2.x requiresJava 8 (Azul Zulu recommended) and openHAB 3 Java 11.
No higher version supported.

1 Like

Uninstalled java 15, installed java 8 and it works fine.

Thanks! That solved it.

1 Like

Reading the docs first is always a good idea :wink: