[solved] openHAB won't start after upgrade to 2.1

Just a heads-up for other users that might experience a similar issue.

I am using the debian packages and upgraded from 2.0 to 2.1. After the upgrade, the service didn’t start any more. The logs were not indicating any error. Reboot didn’t help either.

I then deleted all content of the folders /var/lib/openhab2/tmp and /var/lib/openhab2/cache. Afterwards, the service started successfully and everything works well.


Thanks @bbock! Glad you’re up and running!

@Kai, The deb packages definately delete /tmp and /cache now. So it looks like the first run of an openHAB confuses something in the folder for specific setups some how? Is there any way we can work out what’s going on here?

I have no clue - you are the deb expert :slight_smile: What I always say is that deleting tmp and cache is required for the update, so there must be something fishy going on with apt…

What I have seen (sometimes this happens and I haven’t checked thoroughly):
tmp & cache do get cleaned properly with apt-get upgrade
First startup of OH2 after upgrade does populate the tmp & cache dirs but sometimes errors appear in the logs (and it seems that the process gets stuck somewhere… (to be validated)

Second startup (systemctl restart openhab2 without clearing tmp & cache for a second time) brings up OH2 without any hiccups or any errors being logged

I will investigate more and post my findings.

This is was I suspect also, I’m not conviced that this is apt specific @kai but I have been wrong before :wink:

That would be very helpful, thanks!

I could see something similar.
Changed from unstable main to stable main to get 2.1
in the events log I could see
"removed zzz " for all/many of my devices.
But the web UI didn’t start.

Rebooted several times. No reboot gave any info in op*.log nor ev*.log

I left everything for the night as is.
This morning I logged on from work and lo and behold, the web interface started!
I have no clue why I didn’t see anything yesterday, nor do I know why it works today.
Could there be an update process that needs to be finished?

Update to OH2.2 worked for me by using apt.
In fact, I did upgrade from jessie to stretch. What I did:

  1. systemctl stop openhab2.service
  2. systemctl disable openhab2.service
  3. apt update
  4. apt full-upgrade
  5. edit sources.list to change from jessie to stretch
  6. apt update
  7. apt upgrade
  8. reboot
  9. apt update
  10. apt full-upgrade
  11. reboot
  12. systemctl enable openhab2.service
  13. systemctl start openhab2.service

This worked flawless, maybe there are some timing problems in upgrade process? But maybe I only was lucky… :wink:

Thought I’d found a bug, turns out it’s still behaving correctly, not sure what’s going on