[SOLVED] OpenHAB2 Wemo Maker Sensor


Should the sensor of the Wemo maker work in OpenHAB2? I have it connected to a magnetic reed switch and it’s working in the Wemo android app. The rely works fine in Openhab2.

Log when pressing relay.

10:21:15.277 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘wemo_Maker_Maker_1_0_221444S00000F4_relay’ received command ON
10:21:15.295 [INFO ] [marthome.event.ItemStateChangedEvent] - wemo_Maker_Maker_1_0_221444S00000F4_relay changed from OFF to ON
10:21:22.523 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘wemo_Maker_Maker_1_0_221444S00000F4_relay’ received command OFF
10:21:22.531 [INFO ] [marthome.event.ItemStateChangedEvent] - wemo_Maker_Maker_1_0_221444S00000F4_relay changed from ON to OFF
10:23:43.345 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘wemo_Maker_Maker_1_0_221444S00000F4_relay’ received command ON
10:23:43.354 [INFO ] [marthome.event.ItemStateChangedEvent] - wemo_Maker_Maker_1_0_221444S00000F4_relay changed from OFF to ON

wemo_Maker_Maker_1_0_221444S00000F4_relay (Type=SwitchItem, State=OFF, Label=null, Category=null)
wemo_Maker_Maker_1_0_221444S00000F4_sensor (Type=SwitchItem, State=NULL, Label=null, Category=null).

Yes and no,
in generall, the binding supports the sensor, but due to Belkins bad UPnP implementation, we cannot use GENA event subscriptions fo the maker.
Instead, polling is used to check for state changes. So there might be a chance that the binding misses sensor state changes between two polls.

Thanks, that’s not what I wanted to hear :(. I was starting to like this Wemo gear.

@Blanch, did you ever have any luck? Even with log:set TRACE org.eclipse.smarthome.binding.wemo I don’t see any entries in openhab.log nor events.log when I connect the sensor so I’m wondering if this might be missing altogether. I do see it working in the WeMo app though.

What is your setup connected to the sensor input of your maker device and what result do you see in original WeMo app?

I was using it to determine if the front door was open or closed, but I pulled it off the door and put it on my desk. So for troubleshooting, I am just using two wires, one plugged into the “S” and one plugged into the “-”. Then I connect the wires to each other, I see the wemo app shows as “triggered” and when the wires are not connected the wemo app shows “not triggered”.
When connecting or disconnecting the wires, I do not see any activity in the OpenHab logs.

Thanks for your information. I will try to reproduce what you see and see why the Binding does not show correct state.
Cause of other priorities, I can not say when I will get this issue solved.
Could be with my next Binding version which is scheduled for mid February, but no promises.

Hi @nomadic-squirrel, nope I couldn’t get the Wemo maker sensor working in OpenHAB2. I did manage to get it working in Home Assistant, I’m sure @hmerk will solve this, but I’m no programmer.