[SOLVED] Openhab2 - Xiaomi Mi Gateway - does not respond

openhab2
gateway
xiaomibinding
Tags: #<Tag:0x00007f014afdc300> #<Tag:0x00007f014afe7ed0> #<Tag:0x00007f014afe7c00>

(Aaron) #61

Agreed. There is an obvious pattern here. It doesn’t seem to relate to the MAC… but the functioning devices tend to have version _159 and the non working devices are at _161. Although @wojciech.fred seems to be the outlier here.


(Bart Snijder) #62

What is the type of gateway used that do not work?

There is a apple-homekit compliant version (with Aquara name on front). This could be a reason for some (non-homekit compliant) units not updating further than 1.4.1_159.0143 (and thus working)


(Jesper Borglund) #63

Good point. Both of mine are without the aqara name on the front (model DGNWG02LM) and are updating to 161


(Aaron) #64

Mine looks the same as @Jebo. Can we get confirmation from a working unit at _159 to check if it looks the same? Additionally from the info json:

…“fw_ver”:“1.4.1_161”,“hw_ver”:“MW300”,“model”:“lumi.gateway.v3”,“mcu_fw_ver”:“0143”,“wifi_fw_ver”:“SD878x-14.76.36.p84-702.1.0-WM”…

Also I have a few internal photos (if that helps identification)

:


(Sergey M) #65

Yes! Everything works perfectly!


(Sergey M) #66

I just received an update 1.4.1_161.0143
I will not be updated :slight_smile:


(Aaron) #67

UPDATE: Looks like 161 seems OK now

Agreed; not worth the risk if you have a working platform, although if all devices are starting to get _161 it will be interesting to see if we start seeing more problems reported…


(Rsx2007) #68

Guys, have same problem.
Ordered gateway for Joybuy (Jd) 1.5 month ago.
Port closed.
MAC - 7C:49:EB:XX:XX:XX
It comes with FW 151, updated FW to 157 and ONLY then i enabled LUMI protocol with success message.
After that received FW 159 and 161 and nothing changed…
I have tried to connect through terminal to PC and make factory reset, but it only works to reset subdevices bindings (reset_lumi_bind command), tried factory_mode command. Gate trying to connect to Wi-Fi spot named “default” - so i dont know name for this spot (and ofc pwd) so it fails…


(Dimalo) #69

Just updated to 161 and still working…


(Michael Cumming) #70

Do the version 3 gateways work with this binding? I cannot get it to connect …


(Aaron) #71

Thanks @dimalo that is good to know. Can you confirm yours looks the same as @Jebo 's unit (photo in above post)?

@mjcumming There seems to be a mix of people with the same hardware (v3) that have it working and some that don’t have it working. That’s the problem we’re trying to get to the bottom of.


(Dimalo) #72

Yes I can confirm it looks like in the picture, also the same model DGNWG02LM.


(Jesper Borglund) #73

Strangely enough my GW started to work again yesterday. I had what I think was an unrelated router issue and had to restart my wifi router multiple times.
Some 30 minutes after I noticed that the GW was working again. This leads me to that there are other things impacting this then just the FW🤔


(Aaron) #74

Thanks for the new info @Jebo. I’ve updated my previous posts accordingly. The behavior remains consistent then; working units continue to work.

I’ll hopefully have another (more positive) data point soon. Ordered a GW from Gearbest to compare to the unit I got from eBay (non working) :crossed_fingers:


(Dimalo) #75

Good luck! :four_leaf_clover:


(Kalpesh Patel) #76

I have recently updated to 161…firmware my both gateways still works… i think problem is with new Models in which Details are written in Circular Form.


(Kalpesh Patel) #77

I have this much information from Analysis. I have both Gateways. Firmware is not the issue

Old Gateway as show in picture works fine even after firmware upgrade.


[SOLVED] Xiaomi Mi Smart Home Binding - gateway problem
(Jan) #78

Hi

Using Xiaomi Mi and OpenHAB since one year.

Here is the data from one of my 3 Gateways - still working. Hope it helps to find the problem.

Jan


(Wojciech F) #79

Thank you, @asking, your post introduced very important information.
Could I ask the other users in this thread to check if the back of the devices match the above picture? That is, for “round text description” - it does not work, for “squared text” the udp protocol works fine?

If we confirm this information, we may need to edit the openhab documentation to warn future users.

Of course, this does not mean that the problem has been solved.


(Sergey Lysakovskiy) #80

Confirm that I have the round text description on the device and it’s not working on udp protocol