[SOLVED] Openhabian and Lightwave RF

Hi I have been on forum now which seems for days delving through pages and pages,

Im trying to configure a relay lightwave rf via openhab now when i place the binding into the usr/share/openhab/addons it doesnt seem to execute no binding visable etc I have tried everything has anyone any ideas?

Why are you not installing it through PaperUI?

Where/how are you looking to determine whether or not the binding is installed?

What specifically is “tried everything”?

cheers Rich for response, Ive tried everything in my knowledge, which to be blunt isnt fruitful, I placed the file for the lightwave rf from Alpha12 into the addon folder and im waiting on the link blinking to confirm which is how I interpreted the tutorial, I would be grateful for advice I know its my error which is why Iam fustrated have hue working well and mi-light the software always surprises me…

Also…within paper ui its not listed under binding from the addons tab

What version of OH are you running?

What tutorial are you following? If it is not posted here on this forum or part of the official OH docs tread carefully. There are a lot (most) of third-party tutorials that are completely out of date.

Where did you download the jar file from?

Are the instructions in that tutorial along these lines?


Thanks Rich, It makes sense that its my error, I thought it was because of Openhabian so I changed to the manual way but still no difference, this is what I think I should be doing,

  1. create the lightwave.cfg file place into the services folder
  2. Drop the file I downloaded to the addons folder usr/share/openhab2/addons
  3. Check wifi link is flashing
  4. Confirm by pressing the wifi link to register the device but obviousy I aint getting by stage 3


Running Openhabian

I don’t know this binding but I think that if you have not installed the OH 1 Compatibility Layer like explained in the link I provided it won’t work.

Also, that is a REEEELY old version of the binding.You will be better off getting the binding from


which is the “official” source for 1.x version bindings (I just downloaded it and it is there).

Like I said, the tutorials that random people have written out on the web are almost all way out of date. And they almost all point to specific versions of files instead of pointing to the location of the most recent versions.

You should download the binding from the link I provided above. Then follow the instructions on the link I provided previously to enable the compatibility layer and install the addon.

Ok Ill try that, the compatibility addon I’ll have a break been on it steady then work through and post my finding, have I the binding installation steps correct at least? as in drop into the addon folder

Mostly. You were just missing the initial step of installing the compatibility layer. Also, like you mentioned earlier, you will have to create the lightwaverf.cfg file yourself. I don’t think it will automatically be created when installing a 1.x version binding that hasn’t been modified to work with the 2.x core yet.

cheers Rick daunting task for a noob thanks for the help

I went into openhab console and installed the 1xbinding using command

Feature: Install openhab-runtime-compat1x

But Light doesnt flash on hub to register openhab

  1. install the compatibility layer following the instructions in the link above
  2. download the addon from the link I provided above
  3. extract the lightwaverf jar file from the zip file just downloaded
  4. copy the jar file to the addons folder
  5. create and populate a lightwaverf.cfg file using the instructions on the README (link you provided in posting 8).
  6. follow any other instructions on the readme

I know nothing of this binding so if you do all of those steps in that order I’m not going to be of any more help.

using ssh -p 8101 openhab@localhost, I then used the command

Feature: Install openhab-runtime-compat1x

it returns with no result echo

the lightwaverf.cfg I named it openhab.cfg

Rick I appreciate the help thank you…

That’s right, you need to use the old openhab.cfg file with the compatibility layer.

Ok, if you have the layer installed, the jar in the addon folder and a properly filled out openhab.cfg file you should be good to go.

What do you see in the logs?

You have been most helpful I already feel further lol, anyways I reinstalled fresh expert mode openhabian,

  1. Set Sitemap
    2)Services file
    3)Addon dropped

No Light flashing on hub and can see this error in log:

2017-09-29 12:50:14.118 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: IP[]
2017-09-29 12:50:14.119 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: ReceivePort[9761]
2017-09-29 12:50:14.120 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: Send Port[9760]
2017-09-29 12:50:14.121 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: Register On Startup[true]
2017-09-29 12:50:14.122 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: Send Delay [2000]
2017-09-29 12:50:14.123 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: Timeout for Ok Messages [1000]
2017-09-29 12:50:14.134 [INFO ] [twaverf.internal.LightwaveRfWifiLink] - Starting LightwaveRfWifiLink Connection
2017-09-29 12:50:14.260 [INFO ] [erf.internal.LightwaveRFSenderThread] - Ok message received for 100,!F*p

2017-09-29 12:50:14.261 [WARN ] [htwaverf.internal.LightwaveRfBinding] - No item for incoming message[100,?V=“N2.94D”
2017-09-29 12:52:10.560 [INFO ] [twaverf.internal.LightwaveRfWifiLink] - Stopping LightwaveRfWifiLink Connection
2017-09-29 12:52:10.562 [INFO ] [erf.internal.LightwaveRFSenderThread] - Message not added to queue as we are shutting down Message[{}]
2017-09-29 12:52:10.564 [ERROR] [erf.internal.LightwaveRFSenderThread] - Error waiting on queue
at java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.reportInterruptAfterWait(AbstractQueuedSynchronizer.java:2014)[:1.8.0_121]
at java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:2048)[:1.8.0_121]
at java.util.concurrent.LinkedBlockingDeque.takeFirst(LinkedBlockingDeque.java:492)[:1.8.0_121]
at java.util.concurrent.LinkedBlockingDeque.take(LinkedBlockingDeque.java:680)[:1.8.0_121]
at org.openhab.binding.lightwaverf.internal.LightwaveRFSenderThread.run(LightwaveRFSenderThread.java:111)[207:org.openhab.binding.lightwaverf:]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)[:1.8.0_121]
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)[:1.8.0_121]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)[:1.8.0_121]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)[:1.8.0_121]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[:1.8.0_121]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[:1.8.0_121]
at java.lang.Thread.run(Thread.java:745)[:1.8.0_121]
2017-09-29 12:52:10.566 [INFO ] [twaverf.internal.LightwaveRfWifiLink] - LightwaveRfWifiLink Connection Stopped
2017-09-29 12:52:10.661 [INFO ] [panel.internal.HABPanelDashboardTile] - Stopped HABPanel
2017-09-29 12:52:10.759 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Stopped HABmin servlet
2017-09-29 12:52:10.845 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Stopped Paper UI
2017-09-29 12:52:10.894 [INFO ] [assic.internal.servlet.WebAppServlet] - Stopped Classic UI
2017-09-29 12:52:11.150 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI
2017-09-29 12:52:11.458 [INFO ] [.dashboard.internal.DashboardService] - Stopped dashboard
2017-09-29 12:53:12.042 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at
2017-09-29 12:53:12.059 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at
2017-09-29 12:53:35.467 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'mcauley.sitemap’
2017-09-29 12:53:40.088 [INFO ] [basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
2017-09-29 12:53:40.545 [INFO ] [assic.internal.servlet.WebAppServlet] - Started Classic UI at /classicui/app
2017-09-29 12:53:42.139 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
2017-09-29 12:53:42.591 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
2017-09-29 12:53:42.851 [INFO ] [panel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
2017-09-29 12:53:42.971 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: IP[]
2017-09-29 12:53:42.972 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: ReceivePort[9761]
2017-09-29 12:53:42.974 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: Send Port[9760]
2017-09-29 12:53:42.976 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: Register On Startup[true]
2017-09-29 12:53:42.978 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: Send Delay [2000]
2017-09-29 12:53:42.980 [INFO ] [htwaverf.internal.LightwaveRfBinding] - LightwaveBinding: Timeout for Ok Messages [1000]
2017-09-29 12:53:43.003 [INFO ] [twaverf.internal.LightwaveRfWifiLink] - Starting LightwaveRfWifiLink Connection
2017-09-29 12:53:43.151 [INFO ] [erf.internal.LightwaveRFSenderThread] - Ok message received for 100,!F*p

2017-09-29 12:53:43.167 [WARN ] [htwaverf.internal.LightwaveRfBinding] - No item for incoming message[100,?V=“N2.94D”

At this point I’m going to be of limited help. The binding is installed and at least trying to run. All I can recommend is creating an item, since that is what it already to be complaining about before closing down. Beyond that, you will have to find a lightwave rf user to help.

Yay Thanks Rick for your help with a little work Ive now got relay switching although I’ll have to check coding on items to switch relays as open stop close, but I’m now over the hurdle and excited for what lies ahead.

Hi Rick, Im I correct in thinking that, when I edit the sitemap and add my rooms, do these rooms need an item for the sitemap to be read? I have edited sitemap with rooms etc, but when I edited say one line the sitemap no longer gets lifted for display and the log says ignored