[SOLVED] Openhabian Frontail stopped working


I’m running latest openhabian image and stable OH2.2 version on a rpi3. Suddenly the log viewer (frontail) stopped working over night. I run the “sudo systemctl status frontail.service” command and this is the output:

* frontail.service - Frontail openHAB instance, reachable at http://openHABianPi:9001
   Loaded: loaded (/etc/systemd/system/frontail.service; enabled)
   Active: active (running) since fr. 2018-01-05 18:47:25 CET; 503ms ago
     Docs: https://github.com/mthenw/frontail
 Main PID: 17071 (node)
   CGroup: /system.slice/frontail.service
           `-17071 node /usr/bin/frontail --ui-highlight --ui-highlight-preset ./preset/openhab.json -t openhab -l 2000 -n 200 /var/log/openhab2/openhab.log /var/log/openhab2/events.log

jan. 05 18:47:25 openHABianPi systemd[1]: Started Frontail openHAB instance, reachable at http://openHABianPi:9001.

I’ve tried to reinstall it several times through openhabian-config, but the openhab log viewer still doesn’t work. When i press the openhab log viewer in openhabianpi:8080/start/index, I get a “This webpage is not available, ERR_CONNECTION_REFUSED”, as if the web server is not running,

Any ideas on how to solve this?

Best regards

What happens if you use

Exactly the same :frowning:

Have tried to reboot several times, and now upgraded to OH2 latest snapshot. Still no difference… The log files are not corrupt, as i can tail the log files from ssh.

What web server is frontail using?


So, I finally figured out this as well. I saw some post on this forum regarding similar problems after upgrading OH2. I stopped OH2 and cleared the cache and tmp folder. Then I opened openhabian-config and run a update. After restarting OH2 everything is working fine! :slight_smile:

1 Like