[SOLVED] Openhabian Running Super Slow

  • Platform information:
    • Hardware: RPI 4B
    • OS: ?, just started with Pi :slight_smile:
    • Java Runtime Environment: openjdk 1.8.0_222 (more below)
    • openHAB version: OpenHabian 2.5.0-1

So I just installed OpenHAB on a PI after abondoning the attempt on Windows. In any case when doing anything via Putty the PI is running super slow, it takes minutes to load the PI just to be able to enter in the first command. I have been following the tutorials from BK Hobby and the only thing I have done that may be an issue is that I added a USB thumb drive so that the SD is not getting ran all the time so avoid corrupting it. The process of configuring the card should have taken 10-15 min but it took over an hour.

Any suggestions much appreciated, TIA and Merry Christmas

Can you do a htop or a top command once your on the shell? Then you’ll see the process load and if that’s the issue. Also, is your Pi cool enough? It will throttle once it’s overheating, but with just openhabian running that is probably not the case.
What kind of USB drive did you use? Have you configured it with the openhabian-config tool?


Your going to have to forgive the newbie here, how do you do the htop and top commands. The PI is cool as far as I know the fan is going and I feel no heat on the exit of the fan. I just used a USB stick I had laying around (not to sure what it is in terms of type/speed). I did configure it through the config screen as outlined here… 7:20 of video

Have you looked at the official documentation written by our knowledgeable developers? It is quite good and you should not need any other installation documents.

Oh if you’ve got a fan you’ll be fine!
Just connect with putty as you already did, then enter htop and press return. It will bring up a task list along with some load info.

Ouch, BK Hobby is seriously wrong here.
Thumb drives are as susceptible to corruption as the internal SD card is.
So possibly your drive already got corrupted which would explain slowness although there’s a number of other potential reason such as a constant restarting of bindings or some unfortunate setup to regularly change files, resulting in constant recompilation of rules (start with ‘top’ and ramp up system logging to get a view of what’s going on).

“(stop with ‘top’ and ramp up system logging to get a view of what’s going on).”, sorry what do you mean by this ?. Also how would I revert to SD only vs SD/USB ?

Typo, sorry, I meant to write “start with top”.
See docs how to enable logging. You have read the docs, haven’t you ?
I suggest to enable debug level on org.eclipse.smarthome and eventually org.openhab

Reinstall. And enable ZRAM.


So i reloaded openhabian and it seems to be running faster, quick question. I did install the ZRAM and read the ling but i am confused (possbily becuase I don’t understand how the program fully works yet). In regards to Reboot is says to do it then it says to not do it (known issue) ?

Read again. It was an issue on some platforms but no longer is on current openHABian.
BTW reboot almost never is a good idea as it does not solve problems (may only temporarily cover issues) and openHAB is built to run 24/7.


Agreed on the 24/7 but I do need to move it from my desk to it’s permanent home at some time and want to ensure I do this in the proper fashion.

The proper command is “sudo shutdown -h now”

1 Like

My two cents:
I’ve had a super slow openhabian on a rpi4 too. Problem was that the ssd was not working correctly with the USB3 ports. It did boot eventually but the boot was way slower than with the USB2 port.
Only after many boot attempts I got an io block write error which made me try the other port.
Reason was that the faulty USB port /SSD combination triggered many read attempts / retries that made the system super slow.

1 Like

If it was like the issue wuth z-stick, it presents itself as supporting usb3 when it does not. Adding a (powered) usb2 hub should work as another solution. I think the hub needs to be powered to power the SSD.

I had a separate issue with an external USB3 drive when plugged into a USB3 port. Apparently USB3 patch cords are very sensitive to damage. Replacing the patch cord resolved the issue.

The old cable appeared to work fine on USB2 but not USB3.