[SOLVED] Openhabian wrong URL for Frontail

I installed Openhabian 1.4 on Ubuntu Server 16.04.3 and intially had the problem with Frontail service not working. Todays update fixed that, but I noticed one cosmetic error - launching Open Hab Log Viewer from the Dasboard fails as the URL is set to http://openhabiandevice:9001.

A quick edit to services/dashboard.cfg fixed it, but it would be nice to have a permanent fix.

1 Like

thx!!! have you checked if there’s already an issue logged on github?

Ooops! No, I didn’t check and yes there is an issue logged.

Thanks, Stefan.

I didn’t neither :wink: but I faced the same issue and found your solution. so thanks again

Thanks for the information. A similar thread topic can be found here: Openhabian wrong URL for Frontail

In my case, I changed the hostname from the default openhabianpi to ohpi. The dashboard’s Log Viewer link is a hard-coded URL: http://openhabianpi:9001 so changing the Pi’s hostname breaks the URL.

Full path to the file containing the URL: /etc/openhab2/services/dashboard.cfg

Perhaps the URL in dashboard.cfg should rely on an environment variable like HOSTNAME?