[SOLVED] Owserver install failed - Service: Inactive (dead)

  • Platform information:
    • Hardware: Rpi4
    • OS: Openhabian hassle free installation

Hi Guys,
I installed Openhabian hassle free installation without any problem, and than immediately installed owserver. No other package was installed.
sudo apt-get install owserver owhttpd

Errors were reported during installation

Creating config file /etc/owfs.conf with new version
Setting up libow-3.2-3:armhf (3.2p3+dfsg1-2) ...
Setting up owserver (3.2p3+dfsg1-2) ...
Job for owserver.service failed because the service did not take the steps required by its unit configuration.
See "systemctl status owserver.service" and "journalctl -xe" for details.
invoke-rc.d: initscript owserver, action "start" failed.
● owserver.service - Backend server for 1-wire control
   Loaded: loaded (/lib/systemd/system/owserver.service; disabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: protocol) since Thu 2019-11-28 19:37:38 CET; 59ms ago
     Docs: man:owserver(1)
  Process: 21434 ExecStart=/usr/bin/owserver -c /etc/owfs.conf (code=exited, status=0/SUCCESS)
 Main PID: 21434 (code=exited, status=0/SUCCESS)
dpkg: error processing package owserver (--configure):
 installed owserver package post-installation script subprocess returned error exit status 1
Setting up owhttpd (3.2p3+dfsg1-2) ...
Created symlink /etc/systemd/system/multi-user.target.wants/owhttpd.service → /lib/systemd/system/owhttpd.service.
Processing triggers for systemd (241-7~deb10u2+rpi1) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10+rpi1) ...
Errors were encountered while processing:
Updating FireMotD available updates count ... 
E: Sub-process /usr/bin/dpkg returned an error code (1)
[19:37:53] openhabian@openhab:~$ 

Despite errors Owserver seemed to be active after installation according to following command
sudo systemctl status owserver.service

After reboot Owserver didn’t start. It was reported “dead”.

● owserver.service - Backend server for 1-wire control
Loaded: loaded (/lib/systemd/system/owserver.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:owserver(1)

Could you please help me what is missing to install Owserver correctly?

I removed manually installed Owserver package and than installed it from openhabian-config. It also failed.

AS I can see it is a known issue. Can anybody suggest a workaround?

I don’t have an experience with OWFS, but if you have wire1 running you could use MQTTany. It can connect to the devices and allows remote communication via MQTT. So far it only supports DS18x20-like temperature sensors, but other cam be added.

Thank you, but I have a 1wire extension board what I want to use. It worked on my previous rpi B+ I don’t want to switch to a different solution. I really don’t know how MQTT works.

miccoli’s answer solved the problem to me.