[SOLVED] Parallel ON and OFF switching

Hey Guys,

iam new with OpenHab and i got a problem which iam not able to solve, maybe some of you experts have some tips for me to solve my problem.

I have two Plug-Switches from Gosund (SP111) flashed with Tasmota. I have bind them to OPenhab via PaperUi and the switches are working, but when i switch one Plug on then the other switches on at the same time.
Do you have any explanations from me why the Plug does so?

Iam using OpenHab 2.4.0 with the MQTT binding 2.4.0.

My Configuration can be seen in the screenshot:

Best regards,


I don’t use mqtt but I’ll take a guess that there’s a problem in your mqtt configuration. Those two items are somehow linked together.

Can you show us your item and mqtt configurations?

Here’s a link that might help with the configuration and setup.

I’d say they both have the same topic set in MQTT configuration

Have you linked both things to the same item?

Hey Guys,
thank you for your fast responses. Here are two screenshots of my MQTT configuration in Tasmota:

From my point of view it seems to be configurated correctly, but maybe i oversee something.

@H102: I have read this topic and i have no idea at the moment why this is not working.

Maybe some off you can give me the decisive hint.

Best regards,


Hey Guys,

here are the other Screenshots:

And here is the screenshot of my item file:

We need the screen shots of your channels

@Markus018 if your having issues maybe try changing the Host from openhabianpi to the servers (the raspberry PI) IP address.

Screenshot of Channel Config:

Screenshot of second Channel Config:

The switching on and off works but it only changes both. Do you mean that this could be the problem?

You have a connection so the host address is not the issue. Something else is going on, so please post the logs you have in front tail.

Hey Guys,

something strange happens. I had a blackout and after the rasperry has been rebooted it works without any modifiaction from my side.
Really strange. Next time i try a reboot first. But many thanks for helping.

Glad it’s back up and running.:+1:

Just something you might want to remember when having strange issues or upgrading OH versions is to clean the cache and reboot.

Here’s the commands for this:

sudo systemctl stop openhab

sudo openhab-cli clean-cache

sudo reboot
if you prefer to not reboot but clean cache only then substitute the reboot with
sudo systemctl start openhab

Hope this helps for any future issues.

If you would, please mark the topic as solved by clicking the square box on the post with the solution and edit the title to start with [Solved].