Solved (partly): OH4.1.1-1 deCONZ2.25.3 Switch comes up as lightgroup in inbox

  • Platform information:
    • Hardware: CPUArchitecture/RAM/storage
      Raspberry Pi 3 Model B Rev 1.2
    • OS: what OS is used and which version
      Linux version 6.1.21-v7+ (dom@buildbot) (arm-linux-gnueabihf-gcc-8 (Ubuntu/Linaro 8.4.0-3ubuntu1) 8.4.0, GNU ld (GNU Binutils for Ubuntu) 2.34) #1642 SMP Mon Apr 3 17:20:52 BST 2023
    • Java Runtime Environment: which java platform is used and what version
      OpenJDK 17 (default)
    • openHAB version:
      OH 4.1.1-1
  • Issue of the topic: please be detailed explaining your issue
    Don’t know exactly when this started. It might be after the last update or when I deleted the second deCONZ Gateway (the one bridge thing which shows up as “Phoscon-GW IP:port” instead of “deCONZ-Gateway”). Since I noticed it, switches (1 RWL021 Philips dimmerswitch and 1 ICASA 8 button switch) show up as “lightgroup”(with all the lightgroup-methods/channels) instead of “switch” (and the switch-methods/channels). Before, they showed up as switches.

I tried many things

  • add thing “Phoscon-GW IP:port”,
  • restarting deCONZ and openhab,
  • removed the switch in openhab and Phoscon,
  • started a new discovery in Phoscon: switch discovered itself as Dimmerswitch in Phoscon,
  • renamed switch in Phoscon, looked in openhab inbox and it still asserts to be a lightgroup. I know that reality and quality are myths (at least for some, today) but if I try to switch the lightgroup ON – nothing happens :slight_smile:
  • complete reinstall from openhabian-image, installed deconz/Phoscon with openhabian-config. No change :frowning:
  • Please post configurations (if applicable):
    • Items configuration related to the issue
      These things reside in the inbox with UID deconz:lightgroup:* instead deconz:switch
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue
      Everything is standard (except the deCONZ http-port 8090 and ws-port 9443?). With /etc/systemd/system/deconz.service.d/override.conf
  • If logs where generated please post these here using code fences:
    The log tells me, that there is a new lightgroup-thing.

The installation of deCONZ/Phoscon via openhabian-conf brings up two newly identified things in the Inbox:
deCONZ-Gateway with UIDs like deconz:deconz:homeserver and
Phoscon-GW (IP:port) with UID starting with deconz:deconz:00212E05BFA4.

Being a newbie at that times I used both. Then I started to clean up: Set all the double identified stuff in the inbox to “ignore”. Unfortunately not distinguishing deCONZ and Phoscon thingys.
Then I decided to delete the Phoscon bridge :frowning: (Don’t do this at home :wink: )

This still doesn’t explain why a switch is automatically identified as lightgroup. But I got my switches and functionality back.