SOLVED: Possible to reset Insteon PLM 2413U on error?

Occasionally (often at least weekly) my 2413U PLM will spew a ton of errors visible in dmesg at which point the PLM appears to disconnect and comes back online at ttyUSB1 which breaks everything. I’m hoping the udev rule I wrote will work for the next time it fails but is there any way to reset the PLM when the failure starts? Or should I look at doing something system level?

Also, would there be any harm in adding the same PLM in openhab.cfg as both ttyUSB0 and ttyUSB1 as a failover? Would it automatically pick up and continue working? Ideally I’d just want the reset to happen as quickly as possible so that’s it is transparent to the wife and the Echo so all the orphaned commands don’t come pouring through at once.

There is no way that specifying both ttyUSB0 and ttyUSB1 in the insteonplm config will do failover. I never tested anything more than 1 modem.

The udev rule is the way to go. You can simulate the failure by unplugging the device. For testing, write your udev rule such that it creates a link /dev/insteon, and use that link in the openhab.cfg. That can then be tested pre-failure.

I have done resetting of usb cameras using an approach similar to this:

Problem is that you cannot reference e.g. /dev/ttyUSB0 to execute the usb reset, but need to find the corresponding device in the usb tree. I wrote a udev rule that creates a link (e.g. /dev/insteon-usb), and then called usb reset on that link. Yeah, it’s ugly.

And I strongly suspect your PLM is nearing end of life. It shouldn’t be doing that. Mine at first just died intermittently, then completely went belly up. It never gave me junk data though. Still, in the majority of cases the power supply is the culprit. If you have a substantial number of devices, I strongly recommend using Insteon Terminal to take a dump of the modem database and save it away before it completely craps out on you. The writing is on the wall!!!
If you know how to handle a solder iron you can repair the modem yourself and replace the capacitors with some that hopefully last longer:

I had added /dev/ttyUSB1 as a ‘second’ PLM and built the usbreset command. Resetting the device caused it to failover to USB1 which showed my udev was wrong. Also OH didn’t work with the Insteon devices until restarting.

Fixed the udev rule (51% certain) and issued resets until it went back to ttyUSB0. Had to restart OH again for that. Now my hope is that if my udev rule is properly working and the PLM pukes on itself again to catch it early and issue a reset before it times itself out and resets on its own. If/when it fails I’ll post the message here (as well as Google it) for others who may run into this. And once I know my udev rule is working right (not using a symlink) I’ll post it as well.

How old is the modem? I noticed that the green LED starts to go dimmer as the power supply starts to fail. Obviously hard to judge if you only have one modem…


With some error and trial and vice versa I ended up calling Insteon. Just restored my config to the new PLM since the 2413U has a two year warranty. The new firmware is 2.* something, I should have taken a picture. The old one was v1.c (1426). Essentially never able to go 48 hours without failure even with trying to symlink to /dev/insteon. If everything is still running when the weekend is over that’ll be the longest it will have run in a large number of weeks.

How did you back-up and restore? HouseLinc?

Haha, yes. I tried insteon-terminal but it kept throwing errors on me so I turned to the HouseLinc setup in the VM I keep on that box. Had to update the devices.xml file before it saw the new PLM in HouseLinc though. Fingers crossed!

SOLVED. Not by the new PLM but by replacing the USB cable. All that hair pulling over a USB cable!

Appreciate the post. Bad USB cables is not a very common cause. Good to know how it manifests itself.