[SOLVED] Problem connecting to cloud


(Noam Shaharabani) #1

hello

for a few days i cant connect to the cloud, i dont know what happend, but i dont see anything in the log

the key and uuid is ok, also tried few times to uninstall and reinstall, but there is no sign of connection in the log (even when restart openhab serives there is nothing in the log)

log when reinstalling

2018-12-05 02:52:47.115 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2018-12-05 02:52:48.012 [INFO ] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-misc-openhabcloud'
2018-12-05 02:52:48.020 [thome.event.ExtensionEvent] - Extension 'misc-openhabcloud' has been uninstalled.
2018-12-05 02:54:28.097 [thome.event.ExtensionEvent] - Extension 'misc-openhabcloud' has been installed.

its look like the service is not running, only show “Shutting down openHAB Cloud service connection”

i’m using openhab 2.4 (latest snapshot) running on pi3

JAVA ver

openjdk version "1.8.0_152"
OpenJDK Runtime Environment (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 
1.8.0_152-b76)
OpenJDK Client VM (Zulu Embedded 8.25.0.76-linux-aarch32hf) (build 25.152-b76, mixed 
mode, Evaluation)

please help, thanks


(Angelos) #2

There have been some problems when using the openHAB Cloud connector with anything less than build 161 for JVM (see here: https://www.openhab.org/docs/installation/#prerequisites)

Upgrade manually to a newer Zulu (since the Azul repos are outdated). Check this out: HowTo: Install Zulu Embedded Java on Raspberry Pi 3


(Noam Shaharabani) #3

thanks, update to 191 now its working

dont know what happed and how it work before