[SOLVED] Problem installing Philips Hue binding

Hello guys!

  • Platform information:

    • Hardware: Acer Aspire, 2Ghz CPU, 3GB RAM
    • OS: Ubuntu Server 18.10
    • Java Runtime Environment: 8
    • openHAB version: 2.4 SnapShot #1423
  • Issue of the topic: i’m binding the Philips hue system and it never ends. Although after that when I go to the bindings menu, i can see it, but doesn’t seem to be finished. I mean i cannot edit its properties, seems like a manually added binding. Btw i can uninstall it, it appers even in the logs. When i install it it doesn’t appear.

  • If logs where generated please post these here using code fences:

20:34:42.873 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
20:34:43.452 [INFO ] [mebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
20:35:03.449 [INFO ] [rthome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
20:35:07.154 [INFO ] [i.dashboard.internal.DashboardService] - Started Dashboard at
20:35:07.156 [INFO ] [i.dashboard.internal.DashboardService] - Started Dashboard at
20:35:07.962 [INFO ] [marthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
20:37:58.876 [INFO ] [i.dashboard.internal.DashboardService] - Stopped Dashboard
20:38:02.922 [INFO ] [mebuilder.internal.HomeBuilderServlet] - Stopped Home Builder
20:38:02.951 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Stopped HABPanel
20:38:02.967 [INFO ] [marthome.ui.paper.internal.PaperUIApp] - Stopped Paper UI
20:38:03.104 [INFO ] [.basic.internal.servlet.WebAppServlet] - Stopped Basic UI
20:38:05.800 [INFO ] [i.dashboard.internal.DashboardService] - Started Dashboard at
20:38:05.804 [INFO ] [i.dashboard.internal.DashboardService] - Started Dashboard at
20:38:05.847 [INFO ] [mebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
20:38:05.904 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
20:38:05.939 [INFO ] [marthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
20:38:08.940 [INFO ] [.core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-binding-hue'
20:38:55.361 [INFO ] [i.dashboard.internal.DashboardService] - Stopped Dashboard
20:38:59.403 [INFO ] [mebuilder.internal.HomeBuilderServlet] - Stopped Home Builder
20:38:59.437 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Stopped HABPanel
20:38:59.455 [INFO ] [marthome.ui.paper.internal.PaperUIApp] - Stopped Paper UI
20:38:59.523 [INFO ] [.basic.internal.servlet.WebAppServlet] - Stopped Basic UI
20:39:02.061 [INFO ] [i.dashboard.internal.DashboardService] - Started Dashboard at
20:39:02.065 [INFO ] [i.dashboard.internal.DashboardService] - Started Dashboard at
20:39:02.106 [INFO ] [mebuilder.internal.HomeBuilderServlet] - Started Home Builder at /homebuilder
20:39:02.157 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
20:39:02.184 [INFO ] [marthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui

I upgraded the Ubuntu, restarted the server / service few times. Still nothing. Please help!


Further Java info:

openjdk version “1.8.0_181”
OpenJDK Runtime Environment (build 1.8.0_181-8u181-b13-1ubuntu0.18.10.1-b13)
OpenJDK 64-Bit Server VM (build 25.181-b13, mixed mode)

Please switch to Oracle or Zulu java. OpenJDK isn’t recomended.

1 Like

The gateway went offline somehow, couldn’t connect to it with the official app either. Should have checked this first… Thank you!

I edited this topics title to be more informative and added a few tags to help future searchers. Can you @Peter_Farkas mark this topic solved?

1 Like

Thank you, all good now!

1 Like

On mine, I did
cat /var/log/openhab2/openhab.log
(from a command line) to discover that it was logging the message:
2020-05-26 15:42:43.394 [INFO ] [ue.internal.handler.HueBridgeHandler] - Creating new user on Hue bridge - please press the pairing button on the bridge.

Once I pressed the button and did cat /var/log/openhab2/openhab.log again, it then proceeded to generate a message that a user had been successfully added, and started discovering my devices. But it still never completes the installation in the paper UI.

Maybe that will help someone who is stuck in a similar spot.