[Solved] Problem Update 2.5.0 build 1627

I wanted to upgrade my raspberry from 2.5.0 build 1621 to 1627 via sudo openhabian-config.
Help on this error, not if it is related to OH

[09:54:58] openhabian@openHABianPi:~$ sudo openhabian-config
[sudo] password for openhabian:
2019-06-30_09:55:11_CEST [openHABian] Checking for root privileges... OK
2019-06-30_09:55:17_CEST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2019-06-30_09:55:18_CEST [openHABian] openHABian configuration tool version: [master]v1.4.1-471(0e54232)
2019-06-30_09:55:40_CEST [openHABian] Checking for changes in origin... OK
2019-06-30_09:56:17_CEST [openHABian] Updating repositories and upgrading installed packages...
$ apt update
Ign:1 http://repos.azulsystems.com/debian stable InRelease
Hit:2 http://repos.azulsystems.com/debian stable Release
Hit:3 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:4 https://deb.nodesource.com/node_8.x stretch InRelease
Hit:6 http://archive.raspberrypi.org/debian stretch InRelease
Ign:5 https://openhab.jfrog.io/openhab/openhab-linuxpkg unstable InRelease
Hit:7 https://openhab.jfrog.io/openhab/openhab-linuxpkg unstable Release
Reading package lists... Done
Building dependency tree
Reading state information... Done
8 packages can be upgraded. Run 'apt list --upgradable' to see them.

$ apt --yes upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libexpat1 libexpat1-dev openhab2 vim vim-common vim-runtime vim-tiny xxd
8 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/80.2 MB of archives.
After this operation, 3,072 B of additional disk space will be used.
apt-listchanges: Reading changelogs...
dpkg: unrecoverable fatal error, aborting:
 files list file for package 'libmnl0:armhf' is missing final newline
Updating FireMotD available updates count ...
E: Sub-process /usr/bin/dpkg returned an error code (2)

It seems your .list file corrupted somehow.
Try to use the following:

sudo rm /var/lib/dpkg/info/libmnl0:armhf.list
sudo apt-get install --reinstall libmnl0:armhf


sudo apt update
sudo apt upgrade
1 Like

thank you so much it worked

you’re welcome :slight_smile:

But make sure not the sd card has started degrading.