[SOLVED] Problem using Eurotronic Spirit radiator

  • Platform information:
    • Hardware: Raspberry Pi 3b+ width zwave module
    • OS: Openhabian -> openHAB 2.3.0-1
  • Issue of the topic: Radiator doesn’t change temperature

Hi, i’m trying to change the target temperature of my eurotronic spirit radiator, but it doesn’t work.

My config:
Number:Temperature thermostatLiving2_set “Thermostat Wohnzimmer 2 [%.2f %unit%]” {channel=“zwave:device:Razberry:node2:thermostat_setpoint_heating”}

Setpoint item=thermostatLiving2_set

I also tried the habpanel, but i got the same problem. If i change the temperature, nothing happens.

In the events.log are these lines (Changed bei habpanel):
2019-01-13 22:20:56.322 [ome.event.ItemCommandEvent] - Item ‘thermostatLiving2_set’ received command 19.5
2019-01-13 22:20:56.346 [vent.ItemStateChangedEvent] - thermostatLiving2_set changed from 19.0 ℃ to 19.5 ℃

Also the radiator is marked as online in the paperui.

Any solutions or logs i can check?

Or is the radiator wrong configured? I read something about the mode of the radiator?

Oh and I also tried the econ channel, same effect…

Can you check which value are stored this item:

Number Radiator01_mode                          "Modus" { channel="zwave:device:xxx:nodeyy:thermostat_mode" }

I use this item config, looks similar:

Number Radiator01_heatpoint                     "Heatpoint [%.1f °C]"  			    { channel="zwave:device:xxx:nodeyy:thermostat_setpoint_heating",autoupdate="false" }

Works!!! Thanks!

I’m using your config now but before i completely reinstalled openhab. I think i made somethin wrong when i updated openhab in the past. There were some errors which are gone now.

What ever… it’s updating the temperature now.

One more question.
When i use the knob widget in the habpanel, i can set the tempature down to 8 degree. Is there a way to turn the radiator off with the knob? On the radiator, i can go down to 8 degree, the next step turns off the ratiator.

Ok, after testing everything, it is not working stable…

First, every valve updated the temperature and everything was fine, but then they started to ignore commands or it needed 10 secondes to update.

After some research i found this thread:

So i tried this and updated to the current snapshop (2.5). At the moment, no valve is responding. I followed the instuctions from the thread, i also excluded one valve and included again… Still not working.

I knew using openhab would not be as easy as the fibaro home center or homematic ccu2, but this is realy annoying…

  • I updated openhab using the openhabian-config
    – switched to stable version
  • reboot
  • removed all zwave things (not the controller)
  • deinstalled zwave binding
    – installed binding
  • localizations are set
  • added all zwave items again
    – they are all recognized as Spirit thermostatic valve

Did i forget something? An important step when updating openhab over the openhabian config?

If you were using 2.4 already, then there is no major change with 2.5 as this was merged a long time ago and the thread you referenced is quite old.

It’s hard to know what your issue is - please provide debug logs so we can actually see why this is happening.

Ok, i will post some logs later.

I’m just setting up my openhabianpi complete new to get a clean system (2.4 release). I just started with openhab, so this doesn’t take so much time. =)

So the changes of the thread i linked are in the latest openhabianpi image (Openhab 2.4.0-1)? i don’t need any updates?

And till i get some logs, one more question.
When i configure the serial ports for the Razberry, the last option can’t be set, otherwise, openhab doesn’t start and i just can connect to the console. Or is the third option not required to work properly?

See here:

Maybe a Problem with the Raspberry 3b+?

Also i’m using the small Razberry (i think it’s the first one?) module, not the the second, bigger one. Is there maybe the problem?

The valves are not very far away from the pi, from 3 to 7 meters… no Walls.


Do you own only one of them?

I had the same effect with one of my radiator controller too. Was broken and I replaced him.

No, i got 4 at the moment.

openhab.log is too big, download here:

events.log (26.3 KB)

I changed zwave to debugging, hope that’s right? Do you need something else?

Before i uploaded the files, i changed the temperatures of the valves to 19 with habpanel. Two valves were updated, the other two not.

What happens if you change your item from:




so that you just send a Number without the unit to your thermostat?

Edit: Sorry I just read your log and it seems you already did this. It seems like your Thermostats have some communication errors according to your log.

I had the same configuration with a raspi 3b+ and the Eurotronic thermostats. But I use the ZWAVE.ME USB Stick and have no problems. Maybe its your Zwave controller.

Hm, is there a way to test the controller? Could it be a conflict between raspberry pi 3b+ and the Razberry module (ZME_RAZ_EU)?

And where did you see the communication errors in the log? xD

Why is the UZB stick cheaper then the Razberry module?

I don’t know how to test the controller.

I mean something like this in your log:

‘zwave:device:razberry:node4’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller


‘zwave:device:razberry:node4’ changed from ONLINE to OFFLINE (BRIDGE_OFFLINE): Controller is offline
‘zwave:device:razberry:node4’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE

Just got my UZB Stick. Installed, included all radiators again and… it’s working… All valves are marked as online, no disconnects so far and if i change the temperature 5 times in just a few seconds, every valve is updating instantly!

So, we should find out if that was a problem with the Razberry and the pi 3b+… It would be interesting if someone else tried this combination.

omg… it’s working so perfect now xD

So let the scripting begin. =) And get more of theses valves…

1 Like