[SOLVED] Problem with update to release 2.5

What package is listed in this file?

There is no package listed, the file is not edited;

# The installation package of this openHAB instance
# Note: This is only regarded at the VERY FIRST START of openHAB
# Note: If you want to specify your add-ons yourself through entries below, set the package to "minimal"
# as otherwise your definition might be in conflict with what the installation package defines.
# Optional. If not set, the dashboard (https://<yourserver>:8080/) will ask you to choose a package.
# Valid options:
#   - minimal  : Installation only with dashboard, but no UIs or other add-ons. Use this for custom setups.
#   - simple   : Setup for using openHAB purely through UIs - you need to expect MANY constraints in functionality!
#   - standard : Default setup for normal users, best for textual setup
#   - expert   : Setup for expert users, especially for people migrating from openHAB 1.x
#   - demo     : A demo setup which includes UIs, a few bindings, config files etc.
# See http://docs.openhab.org/configuration/packages.html for a detailed explanation of these packages.
#package = minimal

# Access Remote Add-on Repository
# Defines whether the remote openHAB add-on repository should be used for browsing and installing add-ons.
# This not only makes latest snapshots of add-ons available, it is also required for the installation of
# any legacy 1.x add-on. (default is true)
#remote = true

# Include legacy 1.x bindings. If set to true, it also allows the installation of 1.x bindings for which there is 
# already a 2.x version available (requires remote repo access, see above). (default is false)
#legacy = true

# A comma-separated list of bindings to install (e.g. "sonos,knx,zwave")
#binding = 

# A comma-separated list of UIs to install (e.g. "basic,paper")
#ui = 

# A comma-separated list of persistence services to install (e.g. "rrd4j,jpa")
#persistence = 

# A comma-separated list of actions to install (e.g. "mail,pushover")
#action = 

# A comma-separated list of transformation services to install (e.g. "map,jsonpath")
#transformation = 

# A comma-separated list of voice services to install (e.g. "marytts,freetts")
#voice = 

# A comma-separated list of miscellaneous services to install (e.g. "myopenhab")
#misc = 

Downgrade to OH version 2.4, after it’s up and running, uninstall restdocs via PaperUI. Stop OH, clean the cache and restart. After its up and running then got to openhabian-config tool and select the option 1, then 2, and 3. After that jump down to “apply improvements” and select option 11, 12, 13 and 14. Now exit the tool and restart OH.

After a few minuets you should have access to PaperUI where you can set you location and add restdocs.

I just tested this on my production server and everything worked.

I was going to suggest uncommenting the package line and setting it to standard. Minimal excludes most of the UIs, if I recall correctly.

Just checked my system and it’s set to “minimal” so it should not make a difference.

I’ll try that. I’m back to version 2.4-all is running.

But I has not installed OpenHab with apt, but from a Zip-file. So I get no openhabian-config tool. So can you send me please an screenshot from the tool, that I can see what happend or what I must do manually?

I have always use the openhabain image so not sure about the tool with zip file. Did you try typing sudo openhabian-config at command line and see if you have the tool?

In my version this tool is not available. I also don’t know to install…

Openhabian makes things much easier. If your using the Pi for other things you can still do it as openhabian run on top of stretch/buster.

You can make a backup using sudo openhab-cli backup --full it will tell you the location it’s stored. Move the backup zip to your PC (I use FileZilla) or USB stick. Then flash the openhabian image to your SD and you should have OH 2.5. You can then restore your backup file and everything should work. You can always test this on a spare SD before moving to main card.

If you decide to go this route let me know and I will provide the steps to restore your backup. It’s not much but I type slow.:laughing:

Nice post about openhabian and how to set it up. openHABianPi Initial Setup

1 Like

What OS?
The Release Notes list upgrade instructions for common installation types.

thanks for all reply- it was very helpful.
On the end I’d installed all addons with karaf separately.
The config of the bindings (z-wave, Xiaomi etc) was loaded and accepted from the bindings.
Now I hope it will run.


Similar but slightly different set of problems after upgrading 2.4 to 2.5.0 in openhabian.
I have no karaf console, no 8080 port open and a log showing:

Could not resolve module: org.openhab.binding.zwave [20]

  Unresolved requirement: Import-Package: org.eclipse.smarthome.io.transport.serial

Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

This is a Raspberry Pi 2 installation with filesystem on an SSD and /boot on the microSD card.

I had the 2.5.0 zwave snapshot installed for the past few weeks and decided I would just do an update/upgrade in openhabian-config.
This unexpectedly (for me at least) installed the 2.5.0 update rather than just package updates.
I notice that I need to run
sudo systemctl start openhab2.service manually.
But after encountering the above errors and symptoms I tried a few reboots then a clear cache and a few more reboots.
Re-checked that permissions were all good.
Ran the openhabian-config command once more.
systemctl status reports that the service is active(running).

Even after a power down re-start the same symptoms remain including openhab-cli console failing to get the session.
I have added zwave and serial to addons.cfg.

Any trouble shooting steps I could try with there being no karaf console?
How would I rollback openhabian back to 2.4.0?


I’d think, the karaf console is elementar-please read the docs. With the GUi it was very strange- Paperui was in my case unusable. IT Breaks without an errormessage. In karaf use “feature:list| install” etc, the Tool is handy.

I’d make a backup of the fully OpenHAB to roll back, but I think, you can repair without rollback, karaf will satisfy the depencies…

Thanks @agricola for your reply.
Unfortunately karaf looks to be quite broken. I can get to a console prompt with ./start_debug.sh but I don’t see any of the usual command options.

openhab-cli console
gives :

Logging in as openhab
Failed to get the session.

Maybe some-one can direct me on how to drive the karaf console commands to sort this out.

The logs report

2019-12-21 14:27:39.447 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar
2019-12-21 14:27:44.702 [ERROR] [ternal.service.BootFeaturesInstaller] - Error installing boot features
2019-12-21 14:31:31.822 [SEVERE] [org.apache.karaf.main.Main] - Could not launch framework

Its starting to look like a clean install is needed unless some-one can see what options might be available.

That’s maybe, OpenHAB must start succesfully to launch karaf…

You an try to start karaf separately after the complete start from OH from the console as described in the doc, but if it fails, I don’t know…

Did you remove the manually installed addon(s) first? they could be conflicting with the newer OH.

I’d clear the Cache and after this no addons was installed.

If an older Version is installed, I suggest to uninstall.

I renamed /var/lib/openhab2/tmp/lock.
Cleared the cache again.
Reset permissions again.
Waited a lot longer than I had been (?) and OH started up.
All good now. Back to normal.
Thanks for comments/suggestions.

@robb01 Which permissions have you checked/reset and how?

Easiest way is

openhab-cli reset-ownership

Or you can do it at the openhabian-config menu 10 Apply Improvements, 14 Fix Permissions.