[SOLVED] Raspberry / Openhabian Locked Out - No SSH, no Web UI

Dear Openhabians,

I am really struggling here:
I have a raspberry pi 3 b+ running openhabian for quite a while now. I just had a short power outage and after this, the rapsberry did not come back as before.
I can’t connect via SSH, nor is the web UI available. Every try gives me ERROR CONNECTION REFUSED.
I can see it on my router having the right IP, so it does something. I can ping it as well, but that’s it.
Is there anything I can do? I have Amanda backups and an old SD Image, but that’s my last straw…

Thank you so much!

Have you tried to access the RPI directly, by using a monitor (HDMI) and plugging in a keyboard? FYI, I think you have to plug the keyboard in first.

Not yet, I don’t own a USB keyboard sadly! But I will plug it into my tv and see what I get!

Wireless keyboard with a USB dongle may work just as well. It’s been a while since I tried this but after the keyboard and monitor is plugged in use Alt + F1. If no luck try using F2 thru F4, its one of those number.:roll_eyes:

Ok so I see what is happening, it seems that the file system ist corrupt… First it tries to mount my external HD for one and a half minutes, then this:

You can see the console, that’s a positive.:grin:

Are you booting from the SSD or SD card?

Dear H102,

I think I have solved the problem, thanks to your help!
I have mounted the SD on my PC and removed the line from fstab where I mount the external HD. And voila, it boots without issues now!
No I don’t know what happened to cause this problem, as I have rebooted often without having any of those issues.
But I’m happy all is up and running now.

Again, thank you so much!

Good to hear.:grinning:

Just a thought, have you considered moving everything to your SSD? I’m using an RPI 3+ with SSD and no issues thus far.

Also, keep this link (credits to @Dim) handy, might need those UUID numbers.
https://www.raspberrypi.org/forums/viewtopic.php?t=220470

1 Like

That’s a very good point! I think I will do this.
How did you migrate? Using dd and an Image?

Seems like my HD has changed from sdb to sda and that’s why it wasn’t recognized. Still I have no clue how this happened.

I used openhab-cli backup, then moved the backup to my PC. Copied the openhabian image to my SSD using Etcher, if doing this with Etcher click the gear icon top right corner and select danger mode (just make sure you know where the SSD drive is located).

Next I used this tutorial to set the RPI for booting without SD card.

Then I started the new OH image and used openhab-cli restore /var/lib/openhab2/backups or where ever you placed the backup file.

1 Like

Awesome! I’ll get a SSD for my PI and then use that :slight_smile:

Thanks a lot for the detailed walkthrough!

Not a problem, glad I could help.

If you would please mark the post solved by clicking the square box on the post that provided the answer and add [Solved] to beginning of the title.

Thanks

2 Likes