[SOLVED] RFXCOM binding with RFY protocol and ASA subprotocol

Hello, I have a Rfxcom to control a rollershutter that uses RFY protocol with subprotocol ASA. In windows with RFXmngr it works like a charm, but in openhab don’t works.
My items file looks like:

        Rollershutter	toldo	"Toldo comedor" { rfxcom=">" }

and in the openhab.log i recieve the next line:

       org.openhab.model.item.binding.BindingConfigParseException: Invalid sub type 'ASA' in type 'RFY'!

Is there any way to make it work with the rfxcom binding?


openHAB 1 or 2?

I only have experience with openHAB 2 and have spent the last week working though various issues but not with RFY, I was using Blinds1, so my item definitions look different to yours. I also struggled with low ID’s.

I ended up using an ID of 01 01 01 with unit code 1 in RFXmngr. You then need to convert the HEX ID to decimal for openHAB, so in my case 01 01 01 = 65793. The next thing is 0 in openHAB is the same as 1 for the unit code in RFXmngr. So for my case I used 65793.0 and it all worked.

Hope this helps.

I’ts openhab 1.8.3

I have tried it in decimal, it not works.

Seems that ASA subprotocol is not defined

Have you tried

Rollershutter toldo "Toldo comedor" { rfxcom=">" }

Not sure if it will make a difference, but worth a try. I took me 3 days to sort my issues, but as I say I am using openHAB 2 so the set up is quite different.

Next thing to try is

Rollershutter	toldo	"Toldo comedor" { rfxcom=">" }

See my comment above about the Unit Code.

You could be correct here, as I can’t see this option on the openHAB 2 binding.

Sorry, changing the unit code not works.


I have used the exec binding with the rfxcmd console tool. It works like a charm!

Hi underpop,

i have the same problem.
Please post any further information about your solution - Thanks

First, with the windows util configure the blinds

Second, install Rfxcmd from https://github.com/ssjoholm/rfxcmd

Third, add openhab user to sudoers group

Use the next item for a blind:

Rollershutter frontshutter “front house shutterl” { exec=“DOWN:/usr/bin/sudo /home/pi/rfxcmd/./rfxcmd.py -d /dev/ttyUSB0 -s 0D1A03200000010103A100000000 -v , UP:/usr/bin/sudo /home/pi/rfxcmd/./rfxcmd.py -d /dev/ttyUSB0 -s 0D1A03200000010101A100000000 -v, STOP:/usr/bin/sudo /home/pi/rfxcmd/./rfxcmd.py -d /dev/ttyUSB0 -s 0D1A03200000010100A100000000 -v” }

And the next line in sitemap:

Switch item=frontshutter

The codes in the item file must be configured with next rules:

0D : chain length (14 octets)
1A : trame type (RTS)
03 : subtype ASA
20 : sequence number
010405 : device code configured in rfxcom windows util
01 : unitcode
03 : ordre (up 01 / down 03 / stop 00)
A1 : signal level
00000000 : padding


It works very fine. Thank you.

One question: Is there any documentation or where did you get the information for example Subtype ASA or Up/down/stop?

I have find litle documentation in some forums, and the subtype ASA is by trial-error.