[SOLVED] Samsung TV Model UA55JU6000 Cannot Turn On/Off

I have a Samsung TV model UA55JU6000 that I’m trying to control. The Source Name shows correctly, I can control the volume (and the mute) but I cannot switch it on or off. When trying to switch it off I get error “Could not send command to device on”. I cannot telnet to this port as well. Is it possible my TV uses different port for this feature and is the volume controls using another port ?


The samsung tvs do not accept telnet connections. On any port. AFAIK.
Many “SMART” tvs will not accept network commands for ON and OFF either but accept any other commands such as volume and others. When your TV is OFF then the network port is turned anyway so you wouldn’t be able to turn it on by network.

For the ON and OFF I have had to resort to an IR sender unfortunately. But I can feedback on the actual state of the TV with the network binding.

1 Like

I solved this with the very cheap and reliable Black Bean v3, and thanks to a great tutorial on integrating with openHAB here: https://andrew-klimovski.blogspot.com/2017/06/home-automation-using-black-bean-rm.html