[SOLVED] sendTelegram' is not a member of 'org.eclipse.smarthome.core.th ing.binding.ThingActions'

  • Platform information:

    • Hardware: Linux 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux
    • OS:
      Distributor ID: Raspbian
      Description: Raspbian GNU/Linux 10 (buster)
      Release: 10
      Codename: buster
    • Java Runtime Environment:
      openjdk version “1.8.0_212”
      OpenJDK Runtime Environment (build 1.8.0_212-8u212-b01-1+rpi1-b01)
      OpenJDK Client VM (build 25.212-b01, mixed mode)
  • Issue of the topic: SInce the upgrade frm 2.5.1 to 2.5.2 I get the following error in my rule
    sendTelegram’ is not a member of ‘org.eclipse.smarthome.core.th ing.binding.ThingActions’
    and no telegram message is send anymore. I did already a remive of the telegram binding, and reinstalled it, but no luck.
    Anyone any idea’s ?

my rule
rule “telegram”
Channel “mqtt:systemBroker:mq:Telegram_Sender” triggered
var msg =receivedEvent.getEvent() ;
logInfo(“Telegram”," "+msg)
val telegramAction = getActions(“telegram”,“telegram:telegramBot:bca61409”)

2020-02-28 14:43:02.538 [INFO ] [ipse.smarthome.model.script.Telegram] - fred
2020-02-28 14:43:02.542 [ERROR] [ntime.internal.engine.RuleEngineImpl] - Rule ‘telegram’: ‘sendTelegram’ is not a member of ‘org.eclipse.smarthome.core.t
hing.binding.ThingActions’; line 8, column 7, length 32

Have you properly uninstalled the Telegram v1 action and installed the new binding ?

See also 2.5 issues after upgrade and use code fences next time, please.

I did uninstall the telegram V1 action already in 2.5.1. As of 2.5 i did install the new Telegram binding, and this worked fine in 2.5 and 2.5.1. This error is happening since the upgrade to 2.5.2.

It could be this.

Does a restart of OH resolve the issue?

I restart openhab2 and the problem has gone away, telegramAction is sending messages again.
hope this helps and thanks