[Solved] Setup fails with "Failed to start /etc/rc.local Compatibility."

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B V1.2
    • OS: I dont know, none I guess
    • Java Runtime Environment: also don’t know
    • openHAB version: 2.5.5
  • Issue of the topic: Hey everyone, just a quick heads up, this is my first time using a Raspberry Pi and I don’t know anything, so please explain anything like I’m a dumb person, thanks!

Alright so I tired to install openhabian on my Raspberry Pi but the setup said something like [FAILED] Failed to Start /etc /rc.local Compatability. And now I’m stuck, I can’t connect to openhabianpi:8080 to continue the installation.
I tried to do: sudo /boot/first-boot.sh but it said that the command was not found.
Any help is greatly appreciated :slight_smile:

Make sure you follow the install docs and read the debug guide.

1 Like

I did do it like in the install docs, however I cant execute any command that is mentioned in the debug guide. For example if I type “openhabian-config” it says “bash: openhabian-config: command not found”

This is what I’m seeing after installation

Setup did not finish. I would reimage the card and try again.

Most likely cause internet connection problem. Are you on wired internet?

1 Like

I tried that probably like three times now, still getting the same error. And yes I’m connected via cable.

sudo openhabian-config

it’s in the docs :roll_eyes:

After trying sudo openhabian-config as @mstormi mentioned and it still does not work try changing your DNS to use something like google e.g. then flash a new image.

1 Like

You can try manually logging in after failure and issue these commands.

Sudo apt update

Then sudo apt upgrade

Let them run then try reboot and see if setup completes. I had a failure like this in the past and manually doing the updates fixed it. If this does not work follow the trouble shooting guide in the openhabian docs. Also sometimes the dns can be a problem.

I have had some problems recently updating my pi. Issuing a second update command works. I suspect it is related to my dns setup.

1 Like

that also didn’t work. Thats why I tried to do what the debug guide said, that I have to do sudo bash and then openhabian-config.

I was using the cloudflare DNS before, switching to Google’s DNS fixed everything. Thank you!

Just for good mesure, I tried that before switching the DNS and it also didn’t work.

Thank you to everyone who replied to me!

Glad you got it working :+1: and thanks for posting back what worked to resolve the issue.


hi, i have the same problem.
how do I change the DNS?

You need to edit the content of /etc/resolv.conf .
See e.g. https://wiki.debian.org/NetworkConfiguration#Defining_the_.28DNS.29_Nameservers for debian like systems.

1 Like

That may help but it’s not the right approach.
Your DHCP server (your Internet router, typically) needs to assign DNS server addresses to use to its DHCP clients, and typically the router itself is your DNS server, too. That also means you need to set it up to work like one.
If you don’t properly set that stuff up once and for all clients to work, you’ll keep hitting trouble all along the way.

hello, thanks for the reply. I already have a raspberry running openhab 2.4 and I have never had such problems.
My modem is set with DHCP active but I have manually set some fixed addresses.
Should I change something in my current configuration?

Hello and thanks for the reply,
I checked the data of the file in /etc/resolv.conf and comparing them with the modem configuration they seem correct. I don’t know what else to do