[SOLVED] Somfy Tahoma Binding: Not working properly with new Somfy Connectivity Kit

Hello,
I am using openHAB 3.2 with openHABian. I control my Somfy io-Rollershutters with a Somfy io-Connexoon bridge via openHAB. This works fine.

We now get two new rollershutters which unfortunately only support Somfy RTS. Therefore I bought the new Somfy Connectivity Kit (Somfy Connectivity Kit) which both supports io and RTS. It is cheaper (only 69 €) than two Connexoons (for io and RTS) and seems to be better integrated in the Tahoma World than the Connexoon (e.g. it uses the normal Tahoma app which is much better than the Connexoon apps).

I could properly integrate the Connectivity Kit in openHAB, everything was discovered. However, the basic control of the rollershutters is not working (UP, DOWN).

Log:
2022-02-26 11:12:55.417 [INFO ] [openhab.event.ItemCommandEvent ] - Item ‘MarkiseWohnzimmerrechts_Control’ received command DOWN
2022-02-26 11:12:55.418 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item ‘MarkiseWohnzimmerrechts_Control’ predicted to become DOWN
2022-02-26 11:12:55.424 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MarkiseWohnzimmerrechts_Control’ changed from 0 to 100

As you can see the item changes immediately from 0 to 100.

If I use the Tahoma App, openHAB properly receives the new status, e.g.:
2022-02-26 11:15:38.927 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item ‘MarkiseKucheStrasse_Control’ changed from 0 to 29

What is working: The orientation of my roller shutters can be controlled by openHAB and Tahoma scenarios can be executed.

Any ideas? Or is it necessary to adapt the binding to the new Connectivity Kit?

Thanks

BG

I did some testing whether it is a openHAB problem or a problem on the Somfy side.
I installed Home Assistant via docker and used the Overkiz-Integration. Everything worked fine. The kit was identified as TaHoma Basic Plus.

So I guess that it is necessary to adapt the openHAB Tahoma-binding. Since the Somfy Connectivity Kit will replace the Connexoon this might be important for many users in the future.

Did you try the Somfy myLink Binding?

No. Somfy MyLink is a different device. The Connectivity Kit is a small Tahoma box. It should work with the Overkiz-API (as my Home Assistant test proves). The openHAB-Tahoma-binding is using overkiz (according to its description, so it should be possible to integrate this new device in the binding.

I opened an issue on Github ([somfytahoma] Somfy Connectivity Kit not working properly · Issue #12426 · openhab/openhab-addons · GitHub).

Hi Florian,
I had no idea this Connectivity Kit exists. To distinguish between Tahoma and this Kit I need a trace log of somfytahoma binding during discovery, there should be GET setup response containing all the required information. (delete the PINs and other sensitive data)
Most probably awnings identifies themselves differently and I need to see the identification information.
Can you PM the openhab.log to me, plz?
Thanks
Ondrej

Hello Ondrej,
thanks for your help. After some googling I hope I got the right log for you. If you need any further assistance, please feel free to contact me. I’ll send you the log via PM.

Problem has been solved thanks to Ondrej!

I also have trouble getting the Connectivity Kit to work with openHAB.
Only a gateway is discovered automatically and it says “offline”, no other items show up.

First of all: How do I manually update the Somfy Tahoma binding to the newest version?
Thx for your help!

Hello,

  1. Backup

  2. Delete Tahoma-Binding and corresponding things.

  3. Copy new binding (jar-File) in addons-Folder.

  4. Reboot

  5. Add new thing. Tahoma-Binding is not visible under bindings, but when you add a new thing.

Worked for me!

Thx! Where do I get the jar file from?

See here: [somfytahoma] Detected a new unsupported device: Shutter with widgetName: DynamicShutter · Issue #12458 · openhab/openhab-addons · GitHub

1 Like

Works! Thank you.

Only one (strange) issue remains:
When a blind is moving, I can stop it with the “stop/my” (middle) button in OpenHAB.
But when it is up/down and I press the “stop/my” button in OpenHAB, it does not move to the “my”-position as it does with the physical remote. Is this a limitation?

It does not work for me anymore with the Connectivity Kit. My credentials are not accepted. Should we be using another portal URL?

@mmat No problems here.
@juju1337 my-position with connectivity kit and Tahoma-app did not work originally. However, Somfy has fixed it now (got e-mail this work and tested it). The binding still does not work, however. When stop-button is pressed, my-position is not set.