[SOLVED] Sonoff basic looses switch signal on GPIO14

I do use some sonoff basic with 5.11.1a to read switch signals on GPIO14 and GND.
Therefore I defined GPIO4 as 18 Relay2 and GPIO14 as 10 Switch2.
In my final installation the switch signal will be triggered by a PIR sensor.
So far I still play around to define the rules in openhabian and manually trigger the switch signal to read it in openhabian.

Now my problem. In some cases the switch signal when closing the contacts is just lost, means the sonoff does not recognize, in other words loses the signal.
The contacts are soldered so it definitely can’t be a contact problem.
Does anyone have an idea what could cause this issue?
Is this maybe dependent on the firmware release?

What firmware?
What switch signals?
If it is Tasmota, what is the RSSI value?

As I wrote 5.11.1a tasmota. The switch signal is a manual switch which closes GPIO14 and GND pins.
In almost most cases it works without any problem but I noticed a few times that the manual switch close was just ignored, the Green LED stayed off.
BTW This is an old sonoff basic with GPIO14 still as a separate pin.

So you realy have a Tasmota problem, not openHAB
Please post there:
or there:

Ok thanks

Might need a pullup for solid switching levels.

Don´t understand, can I improve somehow this issue?

Just as @rossko57 mentioned, try using a pullup resistor (start with 10k ohm).


If you have success then please take a few minuets to post what worked (and what value resistor). This will help any others that may run into the same issue.