[SOLVED] Sonoff Tasmota firmware issues

Hi guys,

I’ve got quite a few sonoff basics that were quite happy until I decided to update them all via OTA. Now they’re having mqtt connection issues, I’ve looked on github for known issues but I can’t quite figure it out? I’ve erased them via esptool and refreshed them with the latest Tasmota, they seem ok at first but after a few days they start dropping mqtt connection. I know I probably should be posting this on github but I thought I’d try here first.

An advice would be appreciated

you will get better help in github… as this is OH fourm

but i can give you my two cents of wisdom…
try a diffrent way of flash…

i heard of pepole puting blank sketch and then the thasmota friamwre , some how the ESP will remmber the settings i had that issue with ESPeasy but not with thsomta , its somthing that we are doing wrong
but if you want to work around it try the above

also you can flash with * Atom platfrmio or somthing like that!
good luck

1 Like

I saw the same and reverted back to the version 6.3.0. Now running smooth again.

1 Like

Did you erase the previous flash before reverting back to 6.3? Also some of my older sonoffs were on 5.12 and then I upgraded to 6.4 and I read that you have to migrate? I’m not too sure what that means but I’m guessing jumping firmware may be the issue?

I haven’t updated my sonoffs since 5.4. If they work with all the functions I want for use with OH. Why update?

1 Like

Thanks for that info, i have problems too, but until now not the time to look in that in more deatil. Just to give some more Information. I am using version 6.4.1

If using a sonoff basic you might want to look at troubleshooting “Running out of Memory” found here.

I agree with Vincent, if you have everything working on an older version stick with it. Most of the latest updates are for esp’s with 4 times the memory, all the bells and whistles, and not the greatest thing (In my opinion) for a sonoff basic.

I had problems too with the 6.4.1 and didn’t have time to investigate the behavior yet.
A Downgrade to a lower 6.x.x brought me stability for now.

Also, every time you re-flash you loose a flash cycle and there are only a limited of flashes before the memory get corrupted permanently.
It’s also good practice to turn off all the logging in the sonoff console.


If it’s not broken don’t fix it. I was messing with the items and rules from OH on GitHub that updated them all at the same time via OTA…then they all fell over on 6.4. Now I’m struggling to downgrade them successfully.

If your trying to down grade OTA you need to use the minimal version first. After it’s installed then pick the firmware version you want.

If you can access the devices without having to dig them out I would erase (with esp tool) and flash manually. I use version 5.14 on sonoff basic with no issues but pick what works best for your needs.

:+1: Best way to flash IMHO. Very easy to comment out the stuff you don’t need and reduce the flash size for some of the 6.x versions.

That’s perfect, cheers fella.

Glad you got it working.:+1:

Please click the square box on the post that provided the solution and edit the title to start with [Solved].