[SOLVED] Sonos S2 (new OS) - Binding support?

Sonos has released their new speaker OS and app called S2.

Does anyone know if the new OS breaks compatibility with the OH2 Sonos binding?

According to this thread the UPnP interface is so far intact, however I don’t know if the protocol stands and if the binding need anything else that might have been removed.

Has anyone updated and care to comment?

EDIT: So based on peoples answers I guess we can conclude that the binding works well with S2 :slight_smile:
I also updated my SYMFONISK and it’s still happily communicating with the binding.

I have updated yesterday and did not discover any problems.
Mind you - I did not search for any problems, I can only tell you that openHAB triggered my Sonos player this morning without any errors…

Cool, thank you!
Great to hear :slightly_smiling_face:

I just updated my sonos system (all Player:1) and as far as I see it still works (tried it with a Say-command).

I just updated 15 Player:1’s and 4 Amps and everything is still working with Sonos S2 update to the units.

Best, Jay

Same for me. Updated all players and installed a new Sonos Five that arrived yesterday. The Five was detected correctly (PaperUI Inbox) and all functions I tried so far still work.

Have rules that group speakers, change volumes and start a playlist which all still worked.

Five is certainly not detected as Five as support was not yet added.

I upgraded to S2 yesterday. I see no difference on my setup. Playbar, One, and Play:1 mix.


it might have nothing to do with my update to “S2”, but my Sonos Speaker aren’t working with “playSound” or “say” command any more. Last time I’ve tested this successfully was with “S1”.

Can anyone else confirm this as an issue with S2?

thx Ole.

Tested the say-command on Sonos Play:1 running S2, working!
Even with S1 my system intermittently needed a bundle restart or the like to be performing this command again.

@opus Thanks - then i at least still have a chance to get it back working! Anything special needed for a “bundle restart”. Already having restarted my Pi several time with no change to the better.

However - I will keep trying. Alexa Control Binding might be another chance for my use case, but so far even there the sonos won’t say a word.

Reboot the Sonos device maybe.

About the only change I noticed after the S2 update was the Amp units were rediscovered as “sonos:Amp:”. They were previously “sonos:zoneplayer:”.

I recently upgraded to S2. It seems I can’t start a specific radio station from openhab when I issue the command:


before this seemed to work. Anybody else notice this change? It is a new openhab setup I’m running (since I also moved house) but reused my existing code etc. so can’t seem to find any difference besides running S2 controller instead of S1 before.

EDIT:"Sonos added their own radio service. But when I added TuneIn service again, and the added the specific radio station in the TuneIn playlist, it seems to work… my mistake. :slightly_smiling_face:"

1 Like