[SOLVED] Stopped Instance of OpenHab and now cannot log into GUI (IP:8080)

Release = Raspbian GNU/Linux 10 (buster)
Kernel = Linux 4.19.75-v7l+
Platform = Raspberry Pi 4 Model B Rev 1.2
OH: V2.5

I was trying to clear my cache and it came up with an error saying the file contained items, somewhere in this mess I stopped this instance of OH and think I restarted it (just logged into Putty again), now I cannot access the webserver xxx.xxx.x.xx:8080, any ideas ?

Well, first thing is to verify that you did in fact restart it. If you did, are there errors when you do a systemctl status openhab2? Are there errors in openhab.log?

A vague “saying the file contained items” is almost meaningless to us. We need the error as it appears in your logs.

Dumb newbie question = how do you officially restart ?. Below is the response of (systemctl status openhab2)

systemctl restart openhab

The error from systemctl indicates a permission problem on a lock file. Stop openhab systemctl stop openhab, and clear the cache sudo openhab-cli clean-cache. You also might want to reset the file ownerships. sudo openhab-cli reset-ownership.

So on the restart it got the following…

Failed to restart openhab.service: Unit openhab.service not found.

And when I tried to stop it i got…

Failed to stop openhab.service: Unit openhab.service not loaded.



Many thanks for your time and patience :slight_smile: