[SOLVED] Sudo systemctl status openhab2.service reports failure

I have installed openhab for the first time. I did not get any errors but when I tried browsing to the dashboard, it would not resolve. On checking the service, I noted the following:

sudo systemctl status openhab2.service
● openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor pre
Active: activating (auto-restart) (Result: exit-code) since Wed 2019-10-16 06
Docs: https://www.openhab.org/docs/
Process: 14459 ExecStart=/usr/share/openhab2/runtime/bin/karaf $OPENHAB_STARTM
Main PID: 14459 (code=exited, status=1/FAILURE)

Where can I start looking for the problem?

What did you install OH on and how did you install?

I installed it on Ubuntu Server 18.04. While trying to find the link that I used I realised that I did not have the prerequisites installed correctly. I fix this then then try again later tonight.


Initially I went straight to https://www.openhab.org/docs/installation/openhabian.html#other-linux-systems-add-openhabian-just-like-any-other-software and then referred to the “Other Linux Systems” section. This means that I missed out the Java requirement. I have now installed Zulu and all is well… :blush: