[SOLVED] Switching Graph for different Periods

Chart_intervall is already a number defined item

Number Chart_intervall

Looks light you thought already about everything.

I noticed that the switch seems to have renderer fine on your cell (screenshot in your first post)…I presume the last pic is from your computer, where it does not render…if not used already, could you pls try it with BasicUI and could you try to use a different browser…
not sure what browser, platform and OH version you are using…

I#m using OH2.4 stable and Firefox-Browser. Trying with Chrome makes no difference. With BasicUI, I#Ve no experience and don’t know how to use.

From the docs: https://www.openhab.org/docs/tutorial/sitemap.html
To finally see the result, browse to the initial openHAB start page http://IP-of-your-machine:8080 and click on the “Basic UI” link.
Also see here, in case you want to learn more: https://www.openhab.org/docs/configuration/ui/basic/

Does your new sitemap work on your phone?

So I created the sitemap basicUI and unfortunatly it looks like this:

on my phone the same.
So I’ll give up for today and sleep over it - thanks for your support so far!

I understand from you that you restarted occasionally, did you also Clear the Cache? If not you may want to try that.

I have seen such problems before, my best guess would also have been the definition of the Chart_intervall item ( has to be a number, set in the .items file).
Since that is checked, I am also out of ideas.:face_with_raised_eyebrow:

second that…it is certainly a non-obvious thing…very weird…

some Questions.

have you configured a “GROUP ITEM” in the Sitemap???

Could you remove

label="Temperaturverlauf"	icon="line"	

in the Sitemap and try again???

I have played around in my system (adding and deleting these statements), and these two do not seem to do any harm (at least for me)
Also, the group item was replaced by frame and still …

The switch mappings=[] failing to work is as big a clue as the graphs that something is not rendering at all well.
System reboot would be a good idea I think.
Check the sitemap name matches filename.
Check openhab.log for sitemap related warnings.

And the Group item??

Have you tryed to changed it to Text item???

Have you installed only 1 Persistence Service???

have you tried to remove

service = "rrd4j"

Note that the OP gave up for today, so don’t push it to much.
A second look might reveal what isn’t correct.
The problem is definitely not the persistence.

this leads to solution for switching-problem: the item “Chart_intervall” has not been defined !
Now switches are visible, but no graph is shown:

Ok process…that is good. What happens when you actually click on one of the buttons? Any changes, any errors?
(However, I must say, I am a little confused, did you not post earlier that you defined Chart_Intervall as Number?)

1 Like

yes, your’e right. I don’t know for what reasen it has been disapeared. I think when testing and playing around, it has been deleted. But I also wonder, why it doesn’t work when it has been there. Anyway -
i can click on the buttons and they change colour. In log there apeears:

2019-03-03 11:20:20.621 [WARN ] [.classic.internal.servlet.CmdServlet] - Received unknown command '1' for item 'Chart_intervall'

I’m a bit concerned about the warning, I haven’t seen such in my system.
Do you get a single chary displayed now?

when I comment out the switching and set a single line with chart item, it displays one.

Please show your relevant definitions of items from your .items file and the relevant parf of the .sitemap file in which you are using the switching.

I’ve got it. item Chart_intervall has to defined as Number - not as Switch like I’ve done.
Now its working like a charme. Thank you guys for your hints and patience with me.

1 Like