[SOLVED] Synology Disk usage and SNMP Binding

I am trying to monitor my Disk usage on my nas using SNMP, with the following Oid :

.1.3.6.1.4.1.6574.3.1.1.4.0 = COUNTER64: 2407999590400

This is the result of an SNMPWalk.

But using the Openhab binding, I don’t get any results (just NULL) unlike other values.

My guess is that the type COUNTER64 is not supported by the binding.

Can someone confirm this or not ?

I’m using SNMP binding to monitor Synology disk usage without any issues. Can tell you the used OID tomorrow when I have access to my system. Which version of SNMP (v1-v3) have you enabled on your Syno?

Hi,
I enabled SNMP v1 & v2 on my Synology (DS718+)

The Item configuration is as follow :

Number SynologyDrivePhysicalSizeTotal “SynologyDrivePhysicalSizeTotal” { snmp="<[MYSYNOLOGYIP:public:.1.3.6.1.4.1.6574.3.1.1.5.0:10000]" }

Which is supposed to be the total disk space (raidTotalSize per the MIB)

I also have the same issue with the Uptime

Number SynologyUptime “SynologyUptime” { snmp="<[MYSYNOLOGYIP:public:.1.3.6.1.2.1.1.3.0:10000]" }

But if I get the Disk Temperature (not COUNTER64) it works :

Number SynologyDrivePhysicalTemp “SynologyDrivePhysicalTemp” { snmp="<[MYSYNOLOGYIP:public:public:.1.3.6.1.4.1.6574.2.1.1.6.0:10000]" }

Ok, just checked my installation.
I’m using different OID’s to monitor disk usage of my DS916+

E.g. Volume 1 Used = .1.3.6.1.2.1.25.2.3.1.6.51
This is of type Integer and works without any issues. The last 2 digits (51) can be different, depending on your file system. And you need to multiply the result of this OID by the value of the corresponding StorageAllocationUnit (can also be received via SNMP).

Also for the Uptime I use different OID which is not COUNTER64
.1.3.6.1.2.1.25.1.1.0

Your configuration looks good. So maybe there is really an issue with COUNTER64 OID’s and the binding. I don’t use any so can’t give more feedback on this.

I encountered the same issue trying to read a COUNTER64 from my Mikrotik. Apparantly there is an undocumented extra version parameter you can add, which allows you to read COUNTER64. Just add ‘v2c’ as protocol-version: [url:protocol-version:community:OID:refresh]

See: https://github.com/openhab/openhab1-addons/issues/2426

This should definitely be added to the docs when it works.

Will try that too later for my Synology diskspace.

Thanks a lot, it works now with the v2c in the item definition.

Works for me too.
Thanks for raising a pull request to extend the docs.