[SOLVED] Tado Binding Strange behaviour

Hi There

I’ve been playing around some time now with Openhab2 and during the last couple of months I had mixed results.

Last year I managed to get the unofficial TADO binding working and it did it’s job great!

This year I decided to start over because a lot of new bindings that I can use have been added. The problem that I face right now is that whenever I start from skratch (uninstall/reinstall of Openhab2) I can’t seem to get a good reading from all the items I add via Visual studio. I’m currently working on a Ubuntu installation:

Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial

Running the latest Openhab2


Bridge tado:home:34DF7685 [ username="XXXXXXXXX@gmail.com", password="XXXXXXXXXX" ]  {
    zone LRHeating [id=1]

    mobiledevice Arisa [id=176326]
    mobiledevice Bart [id=855929]



//Tado Thermostat
Number:Temperature HEAT_inside_temperature    "Inside Temperature"      { channel="tado:zone:34DF7685:LRHeating:currentTemperature" }
Number             HEAT_humidity              "Humidity"                { channel="tado:zone:34DF7685:LRHeating:humidity" }
Number             HEAT_heating_power         "Heating Power"           { channel="tado:zone:34DF7685:LRHeating:heatingPower" }
String             HEAT_hvac_mode             "HVAC Mode"               { channel="tado:zone:34DF7685:LRHeating:hvacMode" }
Number:Temperature HEAT_target_temperature    "Set Point"               { channel="tado:zone:34DF7685:LRHeating:targetTemperature" }
DateTime           HEAT_overlay_expiry        "Setting Expiry"          { channel="tado:zone:34DF7685:LRHeating:overlayExpiry" }
Number             HEAT_timer_duration        "Timer Duration"          { channel="tado:zone:34DF7685:LRHeating:timerDuration" }
String             HEAT_operation_mode        "Operation Mode"          { channel="tado:zone:34DF7685:LRHeating:operationMode" }

//Geolocation Devices

Switch             Phone_atHomeA               "Arisa [MAP(presence.map):%s]" { channel="tado:mobiledevice:34df7685:176326:atHome" }
Switch             Phone_atHomeB              "Bart [MAP(presence.map):%s]" { channel="tado:mobiledevice:34df7685:855929:atHome" }


sitemap tado label="Tado"
    Frame label="Heating" {
        Text      item=HEAT_inside_temperature
        Text      item=HEAT_humidity
        Text      item=HEAT_heating_power

        Setpoint  item=HEAT_target_temperature  minValue=5 maxValue=25
        Selection item=HEAT_hvac_mode           mappings=[OFF=off, HEAT=on]
        Selection item=HEAT_operation_mode      mappings=[SCHEDULE=schedule, MANUAL=manual, UNTIL_CHANGE="until change", TIMER=timer]
        Setpoint  item=HEAT_timer_duration      minValue=5 maxValue=60 step=1
        Text      item=HEAT_overlay_expiry

    Frame label="Presence" {
        Text item=Phone_atHomeA
        Text item=Phone_atHomeB

If I open the sitemap on my mobile phone it only show partial information:

It becomes even more strange due to the fact that if I use PaperUI to link the channels that it does work, sort of…

Can somebody help me where I go wrong?

UPDATE: When I link all the channels in Paper UI it does work except for the Heating Power…


I have nothing special to add to the problem you have. I do not yet have sufficient knowledge of the Tado binding.

which version of Tado do you have? I have a Tado 3+
There are some small differences between 3 and 3+. Mainly software.
I think because the 3 has some options that are no longer present in 3+ (or different), that the binding is not working fore me.

Here’s the latest Tado snapshot if you wanna give it a try.


Thanks H102, I’ll give it a try right now!

Hi H102, I tried it but it didn’t have the result expected. I reinstalled Openhab and it’s dependencies and now it’s working. Thank you for your help!

just another question: where or how did you find out the ID for your mobilephone device?