[SOLVED] Tankerkönig no refresh any more after last update

My Things of Tankerkönig doesn’t work any more and put out this error:

My key is well. It works in a self written script without any issue. There must be a fault in my system or in addon.

I don’t want to reinstall complete addon is there another better way?

I would log onto to the Karaf console and restart the binding bundle.
Using bundle:list to get the number of the Tankerkoenig bundle and bundle:restart thenumber.
Additionally reading the documentation :flushed: reveals that changing the refresh interval would restart the Webservice as well!

Did you notice any suspicious log entries when it started?

BTW: No problem observed on my side, so it doesn’t sound like a problem with the server of Tankerkoenig.de

Edit: Could you check before restarting the bundle if the web requests are still performed. You migth need to raise the log level for tankerkoenig to DEBUG. When getting the posted message the binding should NOT stop the web request!

Thanks for your reply. It must be a specific error on my side. But my request api key is valid. I tested it with another script.

Anyway learned again some stuff to debug bindings i find this in my log:

Found ssl handshake problem…

And now i start at documentation where ssl issue is explained… Must i do this every time?

I haven’t seen this SSL problem for some time and I have to admit that the documented solution to overcome it is not provided by me ( it’s a bit over my knowledge). Never heard of anybody having it after it did work!

Could you give some more details on your openHAB installation?
Java version used, openHAB version, openabian installation? or how did you install?

So i installed certificate in different ways but no luck. SSL error stay.

Openhab Version 4.2.7
java version “1.8.0_65”
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ Client VM (build 25.65-b01, mixed mode)
Linux Raspbian GNU/Linux 9

Use this for installation:

Sounds like a typo because the NEXT major upgrade would be version 3!
I guess you meant to state 2.4.7?

My java version reads:

openjdk version "1.8.0_222"
OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)

It seems you did not update your java version since Feb’19 (found the old thread😉).

Hm, ok so i can’t remember how to install java on my pi… Did you have a hint how to update this version?

Update: I installed the package from raspian… This will not be updated it seems if you say its an old version.

Thanks for your help. Issue is solved. Funny… I removed oracle two times… 8 and then there was 7 and then i get openjdk… Now it works.

1 Like