[SOLVED] Telegram plugin not sending messages

  • Platform information:
    • Hardware: Intel Atom
    • OS: Ubuntu 18.04
    • Java Runtime Environment: which java platform is used and what version
    • Java Runtime Environment: OpenJDK 1.8.0_222
    • openHAB version: 2.4.0-1 (package from PPA)
  • Issue of the topic: Telegram plugin not sending messages
  • Please post configurations (if applicable):
    • Items configuration related to the issue
    • Sitemap configuration related to the issue
    • Rules code related to the issue
    • Services configuration related to the issue

/etc/openhab2/services/telegram.cfg contains :


Upon saving the file, the logfile reports
[INFO ] [egram.internal.TelegramActionService] - Bot jbot loaded from config file

However, using sendTelegram(“jbot”,“test”) in the console no message appears in telegram. Als logfiles report nothing, no error message whatsoever.

Same happens when I use the name “nosuchbot”, no error is being generated at all !

Tried to post a message using curl command, works perfectly !
curl --data chat_id=xxx --data-urlencode “text=Hello” “https://api.telegram.org/botyyy:zzzzz/sendMessage

Also found the hint in the forums to clean the cache, but with no help

Any idea how to debug this ?

Many thanks

Have you tried:


Note the -

Yes, tried it out even though I have a 1:1 chat with the bot, not a group chat

As said, using the same (copy/paste) parameters on the command line using curl I can post a message as the bot, therefore assuming my chat ID and token are fine

If only I could get some warning or error message in the logs…

Have you tried it with a rule? I’m not sure that the telegram action can be used in the console.

OMG !!!
yes, actually this only seems to work when called from inside a rule :-:sob:

Many thanks, saved me from investing even more time into this topic !